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Dear learner,

I extend my heartfelt greetings and profound enthusiasm as I warmly wel-
come you to Sreenarayanaguru Open University. Established in Septem-
ber 2020 as a state-led endeavour to promote higher education through 
open and distance learning modes, our institution was shaped by the 
guiding principle that access and quality are the cornerstones of equity. 
We have firmly resolved to uphold the highest standards of education, 
setting the benchmark and charting the course.

The courses offered by the Sreenarayanaguru Open University aim to 
strike a quality balance, ensuring students are equipped for both personal 
growth and professional excellence. The University embraces the wide-
ly acclaimed "blended format," a practical framework that harmonious-
ly integrates Self-Learning Materials, Classroom Counseling, and Virtual 
modes, fostering a dynamic and enriching experience for both learners 
and instructors.

The University is committed to providing an engaging and dynamic  
educational environment that encourages active learning. The Study and 
Learning Material (SLM) is specifically designed to offer you a compre-
hensive and integrated learning experience, fostering a strong interest in 
exploring advancements in information technology (IT). The curriculum 
has been carefully structured to ensure a logical progression of topics, 
allowing you to develop a clear understanding of the evolution of the 
discipline. It is thoughtfully curated to equip you with the knowledge and 
skills to navigate current trends in IT, while fostering critical thinking and 
analytical capabilities.The Self-Learning Material has been meticulously 
crafted, incorporating relevant examples to facilitate better comprehen-
sion.

Rest assured, the university's student support services will be at your dis-
posal throughout your academic journey, readily available to address any 
concerns or grievances you may encounter. We encourage you to reach 
out to us freely regarding any matter about your academic programme. It 
is our sincere wish that you achieve the utmost success.

Regards, 
Dr.  Jagathy Raj V. P.						      01-01-2025
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1 Basics of Data 
Handling in 
Excel



Experiment 1
Introduction to Excel

Discussion

1.1.1 Introduction to Microsoft Excel

Launched by Microsoft in 1985 for the Macintosh computer, Microsoft Excel is a 
powerful spreadsheet software designed for creating, editing, and analyzing data in 
various formats. During its development, it was code-named “Odyssey.” As one of 
the earliest spreadsheet programs, Excel distinguished itself by introducing pull-down 
menus and mouse functionality into a graphical interface. Excel secured its position as 
a market leader with the release of Excel 2.0 for Windows in 1987, which featured a 
visually rich interface and a host of innovative features. Over time, regular updates have 
enhanced its compatibility, security, and capabilities. Microsoft has released multiple 
versions of Excel, from Excel 95 to Excel 2021. Additionally, the Microsoft Office 
suite provides both mobile and web browser versions, making Excel accessible across 
different platforms.

Excel provides a robust set of tools for data analysis and visualization. Users can 
create a variety of charts, including pie charts, bar graphs, line graphs, scatter plots, 
and histograms, to effectively present data. Features like pivot tables and pivot charts 
enable users to summarize and filter large datasets based on specific criteria. Advanced 
analytical tools such as Solver, Goal Seek, Scenario Manager, and Data Table further 
enhance Excel’s functionality. Additionally, tools like Power Query and Forecast Sheet 
allow users to efficiently manage and analyze large volumes of data. Microsoft Excel is 
versatile and widely applicable across multiple industries and fields.

Excel plays a crucial role in data science and analytics by providing a versatile platform 
for data organization, manipulation, and analysis. It allows data scientists and analysts to 
efficiently clean and preprocess data, apply statistical functions, and perform calculations 
using built-in formulas and pivot tables. Excel’s powerful data visualization tools, such 
as charts, graphs, and conditional formatting, help to uncover patterns and insights from 
large datasets. Additionally, it supports data import and export from various sources, 
integrates with other Microsoft Office tools, and enables automation through macros 
and VBA (Visual Basic for Application), making it an essential tool for both beginners 
and professionals in the field of data science and analytics.



Here are the key features of Microsoft Excel:

1.	 User-Friendly Interface

Excel provides a simple and intuitive Ribbon Interface with tabs like Home, Insert, 
Formulas, and Data, combined with worksheets organized into numbered rows and 
lettered columns, making data organization seamless and user-friendly.

2.	 Data Entry and Management

Excel allows you to efficiently enter, store, and manipulate data in rows and columns, 
with features like Data Validation to ensure accuracy by setting rules for data entry and 
Find and Replace to simplify editing large datasets.

3.	 Functions and Formulas

Excel offers built-in mathematical, statistical, logical, and financial functions like 
SUM, AVERAGE, IF, and VLOOKUP, and allows users to create custom formulas for 
complex calculations, while also supporting dynamic formulas using relative, absolute, 
and mixed cell references.

4.	 Data Visualization

Excel enables the creation of visual representations of data using charts and graphs such 
as Pie, Line, Bar, and Histogram, while Conditional Formatting highlights trends with 
colours, icons, or bars, and Sparklines offer small, in-cell charts for quick insights.

5.	 Data Analysis Tools

Excel provides powerful tools like PivotTables to summarize and analyze large datasets 
effectively, What-If Analysis tools such as Goal Seek, Scenario Manager, and Data 
Tables for predictive analysis, and Sorting and Filtering options to organize and extract 
specific information from datasets.

6.	 Collaboration and Sharing

Excel offers powerful tools like PivotTables for summarizing and analyzing large 
datasets, What-If Analysis tools such as Goal Seek, Scenario Manager, and Data Tables 
for predictive analysis, and Sorting and Filtering options to organize and extract specific 
information. It also supports real-time collaboration via the cloud (e.g., OneDrive), 
allows you to protect sheets and workbooks with passwords or restricted editing 
permissions, and makes it easy to export to PDF or share spreadsheets via email.

7.	 Templates

Excel offers pre-designed templates for common tasks such as budgets, invoices, 
schedules, and reports, making it easier to get started with structured and professional 
documents.
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8.	 Formatting Options

Excel provides rich formatting capabilities, including font styles, cell borders, shading, 
and number formats (such as currency, percentages, and dates), along with themes and 
styles for creating professional and consistent designs.

9.	 Data Import and Export

Excel allows you to import data from CSV (Comma-Separated Values) files, databases, 
or web queries and export files to various formats such as PDF, CSV, or XML.

Note: A CSV file is a text file that contains tabular data with each value is separated by 
a comma(,).

10.	Macros and Automation

Excel allows you to use VBA (Visual Basic for Applications) to automate repetitive 
tasks and record macros for actions like formatting or data manipulation.

11.	Multi-Sheet Workbooks

Excel allows you to perform calculations across multiple sheets and link data between 
them, as well as consolidate data from various sources into a single workbook.

12.	Printing and Page Setup

Excel lets you set print areas, adjust margins, and preview layouts before printing, 
while also supporting page orientation, headers/footers, and scaling to fit data on a 
single page.

13.	Add-Ins and Integration

Excel integrates seamlessly with other Microsoft Office apps like Word and PowerPoint 
and allows you to enhance its functionality using Excel Add-Ins, such as Solver and 
Analysis ToolPak.

14.	Data Security

Excel allows you to protect sensitive data using encryption, password protection, 
and restricted access, while also enabling track changes to monitor edits made by 
collaborators.

15.	Accessibility Features

Excel offers tools such as keyboard shortcuts, screen reader compatibility, and large 
font options to improve usability and accessibility.

16.	Cloud Support

Excel seamlessly integrates with Microsoft 365 for cloud storage and backup, allowing 
you to access and edit files from multiple devices using OneDrive or SharePoint.
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1.1.2 Overview of Excel Interface and Features

In Excel, understanding the concepts of workbook, worksheet, and cells is fundamental 
to effectively working with data. So let us start from the basics of Excel. 

1.1.2.1 Starting Excel

To open Excel in computer, follow the steps given below:

	♦ Click on “Start menu” 

	♦ Then look for “All Programs” 

	♦ Double-click on the “Excel” icon to launch the application

After launching Excel, the Excel Start Screen will appear as shown in Fig 1.1.1. In this 
screen, you can see options - to create a new workbook, choose an already existing 
template, and access the workbooks recently saved and edited by the user.

Fig 1.1.1 Excel Starter Screen

From the Start Screen, select “Blank workbook” to open the Excel interface and start 
working on a new Excel worksheet. This is shown in the Fig 1.1.2. The worksheet 
starter screen is the initial interface that appears when you open the Excel application.
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Fig 1.1.2 Workbook

A workbook is made up of multiple worksheets, each capable of storing data. Worksheets 
are grids composed of columns and rows, with cells where data is entered. Workbooks 
provide a way to organize related data, apply formatting, insert charts and images, 
and perform calculations using formulas and functions. They can be saved as files, 
shared with others, and offer a structured framework for managing and analyzing data 
in Excel. An example of a workbook is shown in Figure 1.1.2.

A worksheet is a collection of rows and columns within Excel. It offers various features 
and functions, such as performing complex calculations, creating charts and graphs, 
and applying formatting to cells. You can adjust the size of rows and columns to fit 
different types of data. Worksheets provide an organized structure for data analysis 
and reporting. You can easily switch between worksheets within a workbook to work 
with multiple datasets or organize information into different categories. By default, a 
new workbook starts with one worksheet, but additional worksheets can be added or 
removed as needed. Each worksheet is identified by a name, typically displayed at the 
bottom of the Excel window, such as Sheet1 or Sheet2, as shown in Figure 1.1.2. A cell 
is formed where a row and a column intersect.

Cells are the fundamental units where data is entered and stored in a worksheet. Each 
cell is identified by a unique combination of a column letter and row number. Cells can 
hold various types of information, including text, numbers, formulas, or functions. They 
act as the core components for organizing, manipulating, and analyzing data in Excel. 
Offering a wide range of functionalities and customization options, cells allow you to 
perform calculations using formulas or functions that reference other cells, enabling 
efficient data analysis. Cells can also be formatted to display data in different formats, 
such as dates or currency, and customized with various fonts, colours, and alignments. 
Additionally, they can be copied, moved, or formatted based on specific conditions or 
data values.
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1.1.2.2 Excel interfaces

The Excel interface consists of various components that facilitate data management, 
analysis, and visualization. When you start the Excel application the basic window of 
Excel will be as shown in Figure 1.1.3.

Fig 1.1.3 Components of Excel Sheet

File Tab: The Office button from Excel 2007 has been replaced with the File tab. You 
can click it to go to the Backstage view, where you can find options to open or save files, 
create new sheets, print a sheet, and do other file-related operations.

Quick Access Toolbar:  The Quick Access Toolbar is available in the upper left corner. 
As the name suggests it includes functions that you want to use quickly and is simple to 
customize the options available in that.

Title bar: It is available at the top-middle part of the window. The title bar shows the 
titles of the program and the working sheet.

File tab: It is used to open or save files, create new sheets, print a sheet, and do all the 
file-related operations.

Ribbon: It contains all the main tabs and its subsequent features. Each tab is divided 
into sub-groups, for example, the Home tab contains Clipboard, Font, Alignment, 
Number and Styles, etc. Each group has also a triangular icon in the lower right corner 
and clicking on this will bring up additional options.

Formula bar: This is the area where you can enter the formula.

Row Bar: The numbering of Rows starts from 1 and keeps on increasing as you enter 
data. The maximum limit is 1,048,576 rows.

Column Bar: Columns are numbered from A and keep on increasing as you keep 
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entering data. After Z, it will start the series of AA, AB, and so on. The maximum limit 
is 16,384 columns.

Status Bar: This shows the status of the active cell in the worksheet. A cell can be in 
one of the four states (i) Ready mode, (ii) Edit mode, (iii) Enter mode, and (iv) Point 
mode.

Zoom Control: You may zoom in or out by moving the slider on the zoom control to 
the left or right. The + buttons can be clicked to increase the zoom factor.

View Buttons: You can switch between sheet views by pressing any of the three buttons 
that are situated to the left of the Zoom control, towards the bottom of the screen.

1.1.3 Creating a new workbook

Creating a new workbook in Excel involves starting a new file that serves as a container 
for multiple worksheets, allowing you to work with different sets of data and perform 
various tasks within a single file. There are many ways to start working with a workbook 
in Excel. You can either choose to create a new workbook or select an already existing 
template or open an already existing workbook. This is shown in Fig 1.1.4 

Steps for creating a new workbook

Method 1: Using the File Menu

1.	 Open Microsoft Excel 
Launch Excel from your desktop or Start menu.

2.	 Go to the File Menu 
Click on the File tab in the top-left corner.

3.	 Select New 
From the options on the left panel, click New.

4.	 Choose a Blank Workbook 
Under the “New” section, select the option Blank Workbook.

5.	 Start Working 
A new workbook will open, ready for you to enter data.

Method 2: Using a Shortcut

1.	 Open Excel.

2.	 Press Ctrl + N on your keyboard.

3.	 A new workbook will be created instantly.
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Method 3: From an Existing Workbook

1.	 If you’re working on an existing workbook:
	♦ Go to the File menu.
	♦ Select New.

2.	 Choose Blank Workbook or a template from the available options.

Method 4: From the Excel Icon

1.	 Right-click on your desktop (Windows).

2.	 Select New > Microsoft Excel Worksheet.

3.	 Rename the file as needed and double-click it to open.

Method 5: Using Excel Templates

Instead of a blank workbook, you can choose a pre-designed template:

1.	 Go to File > New.

2.	 Browse through the available templates.

3.	 Select one, customize it, and save it.

Fig 1.1.4 Creating a new workbook 
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When you open Excel for the first time, it will show a starter screen and you can either 
create a new workbook or select an already existing file, or choose from any existing 
template as shown in Fig 1.1.4.  Once you select the “blank workbook” option a blank 
screen will open with all the options to start working. This is shown in Fig 1.1.5

Fig 1.1.5 Blank Workbook

If you want to create a new workbook apart from the one you have already opened, 
click on the File tab, and then click on the ‘New’ in the left column, and then select 
‘Blank workbook” (Refer Fig 1.1.4).

Creating a new worksheet

A worksheet in Excel is a single page or tab within a workbook that contains cells 
organized in rows and columns. It is where you input, calculate, and analyze data. By 
default, a new Excel workbook contains one or more worksheets, and you can add, 
rename, or delete worksheets as needed.

Worksheets are often given default names like “Sheet1,” “Sheet2,” etc. There are 
1,048,576 rows and 16,384 columns in a spreadsheet, which equals to 17,179,869,184 
cells.  If you already have an existing workbook open in Excel, you have a couple of 
options to create a new worksheet:

Steps to Create a New Worksheet in Excel

Method 1: Using the “+” Button

1.	 Open the Workbook: Open the Excel workbook where you want to add a 
worksheet.

2.	 Locate the Worksheet Tabs: At the bottom of the Excel window, find the 
tabs labelled “Sheet1,”.

3.	 Click the “+” Button: Click the small “+” button next to the last worksheet 
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tab. A new worksheet will be added, typically named “SheetX” (e.g., 
“Sheet2”).

Fig 1.1.6 Creating new worksheet

Method 2: Using the Ribbon Menu

1.	 Open the Workbook: Open your Excel workbook.

2.	 Go to the Ribbon: Click on the Home tab in the Ribbon.

3.	 Find the Insert Option: In the “Cells” group, click the Insert dropdown.

4.	 Select Insert Sheet: Choose Insert Sheet from the dropdown menu to 
create a new worksheet.

Fig 1.1.7 Inserting worksheet

Method 3: Keyboard Shortcut
1.	 Open the Workbook: Ensure the workbook is open.
2.	 Use the Shortcut: Press Shift + F11 on your keyboard. A new worksheet 

will be added instantly.

Method 4: Right-click on an Existing Worksheet
1.	 Open the Workbook: Open the workbook where you want to add a worksheet.
2.	 Right-click on a Tab: Right-click on the tab of an existing worksheet.
3.	 Select Insert: Choose Insert... from the context menu.
4.	 Choose Worksheet: In the “Insert” dialog box, select Worksheet and click 
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OK.

 

Fig 1.1.8 Inserting worksheet

Renaming the New Worksheet

After creating the worksheet, you can rename it:
1.	 Double-click on the worksheet tab.
2.	 Type the desired name.
3.	 Press Enter to save the new name.

Fig 1.1.9 Renaming the worksheet
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1.1.4 Entering data in Excel
The sheet area is where you type the desired text. The insertion point is the area where 
text will appear as you type and is represented by the flashing vertical bar. When you 
click on any cell in the sheet area then that cell will get highlighted. When you double-
click the cell, the flashing vertical bar appears and then you can start entering your data.
There are various methods to enter data in Excel. They are as follows:
Directly typing data into the cells

Fig 1.1.10 Typing data into Excel

The most straightforward method is to directly type the data into the desired cell. Click 
on the cell where you want to enter the data and start typing. Press the Tab button on the 
keyboard to move to the next cell. Here in Fig 1.1.10, we have typed in text, numbers, 
and a combination of both.

Copying and pasting from other sources

Fig 1.1.11 Copy Pasting data into Excel
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If you have data from another source, such as a website, document, or another Excel 
file, you can copy the data and paste it into Excel. Select the source data, right-click, 
choose “Copy,” then navigate to the Excel worksheet, click on the destination cell, 
right-click, and choose “Paste.” Here in Fig 1.1.11, we have pasted the data from 
another worksheet.

Importing data from external sources

Fig 1.1.12 Data Ribbon for importing data

Excel provides various options to import data from external sources like text files, CSV 
files, databases, and other formats. You can use the import features, available under the 
“Data” tab in the Excel ribbon (as shown in Fig1.1.12), to import and populate your 
worksheet with data from external sources.

Entering various kinds of data in Excel involves using different techniques based on the 
type of data you are working with. 

1.1.5 Saving a Workbook

Saving a workbook in Excel ensures that your data and changes are preserved for future 
use.

The different methods or ways by which an Excel file can be saved are as follows.

Steps for Saving Workbook for the First Time

1.	 Open Your Workbook: Make sure you’ve created or opened a workbook 
in Excel.

2.	 Go to the File Menu: Click the File tab in the top-left corner of the Excel 
window.
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3.	 Click “Save As”:

	♦ For Excel 2019/365: Choose a location, such as This PC or OneDrive, 
and click Browse to select a folder.

	♦ For earlier versions: Directly select the folder location to save the file.

4.	 Enter a File Name: In the “File name” field, type the name for your 
workbook.

5.	 Choose a File Format: In the “Save as type” dropdown, select the desired 
format, e.g.:

	♦ Excel Workbook (.xlsx): For standard Excel files.

	♦ Excel 97-2003 Workbook (.xls): For backward compatibility.

	♦ CSV (.csv): For plain-text spreadsheet data.

6.	 Click Save: Your workbook is saved in the specified location.

Saving Changes to an Existing Workbook

1.	 Make Changes: Edit your workbook as needed.

2.	 Click Save: Press Ctrl + S on your keyboard, or click the save icon (a floppy 
disk) in the top-left corner of the Excel window.

3.	 Done! Your changes will be saved to the same file without creating a new 
one.

Saving a Copy of the Workbook

1.	 Go to File Menu: Click File -> Save As.

2.	 Choose a Different Name or Location: Change the file name or location to 
create a copy.

3.	 Click Save. This creates a new workbook with the changes while preserving 
the original.

Autosave option is available inOffice 365/Excel Online, toggle the Autosave 
option in the top-left corner to automatically save your work periodically.

Saving a Workbook with a Password (Optional)

1.	 Go to Save As: Click File -> Save As.

2.	 Open Tools Menu: In the “Save As” dialog, click Tools (next to the Save 
button) and select General Options.
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3.	 Set a Password: Enter a password to open or modify the workbook and 
click OK.

4.	 Click Save. The workbook is now password-protected.

Now let us save the list of customer details with the filename “bank-customer”.

Fig 1.1.13 Saving Excel workbook

After we have saved the file, we can see that the name in the title bar has also changed. 
Saving files in Excel is a crucial step to ensure that your work is preserved and can be 
accessed later.  Use keyboard shortcuts like Ctrl + S or F12 to save Excel files.

Method 2: Using File Explorer (Windows)

1.	 Locate the File:

	� Open File Explorer and navigate to the folder where the Excel file is 
stored.

2.	 Double-click the File:
	� Double-click the Excel file (e.g., example.xlsx). It will open directly in 

the Excel application.

Method 3: Using File Explorer (Windows)

1.	 Locate the File:
	� Open File Explorer and navigate to the folder where the Excel file is 

stored.

2.	 Double-click the File:
	� Double-click the Excel file (e.g., example.xlsx). It will open directly in 

the Excel application.
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Exercise Questions 

1.	 Create a workbook named “Schedule.xlsx.” Add worksheets for “Day1,” 
“Day2,” and “Day3.” Enter the current date and time in cell A1 of each 
worksheet. Save the file.

2.	 Open Excel and create a new workbook. Add your name as the title in cell 
A1. Save the workbook as “MyFirstWorkbook.xlsx” in your Documents 
folder.

3.	 Create a new workbook, add three worksheets, and rename them as “Sales 
Data,” “Employee Records,” and “Summary.” Save the file as “Company_
Data.xlsx.

4.	 Open a workbook and add a new worksheet named “SalesData.” Change its 
tab colour to blue. Save the workbook as “SalesReport.xlsx.

5.	 Insert a new worksheet into an existing workbook and move it to the first 
position.

6.	 Copy a worksheet named “Report” and rename the copied worksheet as 
“Report_Backup.

1.1.6 Navigating and Selecting Data in Excel

Navigating and selecting data in Excel refers to the process of moving through the 
worksheets and selecting specific cells, rows, or columns to work with. You can 
navigate within a worksheet by using the arrow keys on the keyboard, the scroll bars, 
or by clicking on the desired cell.

Moving within the Worksheet:

	♦ To move between cells: You can use the arrow keys on your keyboard to 
navigate up, down, left, or right within the worksheet. Each press of an 
arrow key will move the selection to the adjacent cell in that direction. Press 
the Tab key to go to next the column and Press the Enter key to go to the 
next row

	♦ To move to the beginning or end of a row or column: You can use the Home 
and End keys on your keyboard. Pressing the Home key will move the 
selection to the first cell of the row or column while pressing the End key 
will move it to the last cell.

	♦  To move to the edge of the data range: You can hold down the Ctrl key on 
your keyboard and press an arrow key. For example, Ctrl+Down Arrow will 
take you to the last filled cell in the column, Ctrl+Up Arrow will take you 
to the topmost filled cell, Ctrl+Right Arrow will take you to the last filled 
cell in the row, and Ctrl+Left Arrow will take you to the leftmost filled cell.   
Press the right Alt + Enter to enter a new line in the same column.  Navigate 
cells using arrow keys, Home/End keys, Ctrl key with arrow keys and right 
Alt + Enter keys.
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Selecting Cells, Rows, and Columns:

	♦ To select a single cell: Simply click on the desired cell with the mouse cursor, 
and it will be selected. The selected cell is indicated by a thick border.

Fig 1.1.14 Selecting a single cell

	♦ To select a range of cells: Click and hold the mouse button on the starting 
cell, then drag the cursor to the ending cell of the desired range. Release 
the mouse button, and all the cells within that range will be selected. The 
selected cells will be highlighted.

Fig 1.1.15 Selecting ranges of cells

	♦ To select an entire row or column: Click on the row number or column letter 
to select the entire row or column. For example, clicking on the row number 
“3” will select the entire row 3, and clicking on the column letter “D” will 
select the entire column D.
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Fig 1.1.16 Selecting entire row 

	♦ To select multiple non-adjacent cells or ranges: Hold down the Ctrl key on 
your keyboard while selecting individual cells or ranges. Each selected cell 
or range will be added to the existing selection. To select cells, click on a 
single cell or drag the mouse to select a range.

Fig 1.1.17. Selecting multiple cells or ranges

Selecting Data with Keyboard Shortcuts

	♦ To select adjacent cells: Click on the starting cell, hold down the Shift key 
on your keyboard, and then click on the ending cell. All the cells between 
the starting and ending cells will be selected, and the entire range will be 
highlighted.

	♦ To select entire rows or columns: Use the Shift key in combination with the 
arrow keys. For example, to select multiple rows, click on the first row you 
want to select, hold down the Shift key, and press the Down Arrow key to 
extend the selection to multiple rows.

	♦ To select the entire worksheet: Press the Ctrl + A keys together. This 
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keyboard shortcut selects the entire worksheet, highlighting all cells, rows, 
and columns. Use Shift + click, Shift + arrow keys, and Ctrl + A to select 
data.

1.1.7 Opening an Excel File

Opening an Excel file means accessing a workbook (.xlsx, .xls, .csv, etc.) stored on your 
computer or in the cloud to view, edit, or analyze its content. Excel supports various file 
formats, including Excel workbooks, CSV files, and templates. The process involves 
navigating to the file’s location and loading it into the Excel application.

Method 1: Using the Excel Application

1.	 Open the Microsoft Excel application from your desktop, Start menu, or 
taskbar.

2.	 Go to the File Menu in the top-left corner.

3.	 From the menu, click Open.

4.	 Choose the File Location Under the “Open” menu

	♦ This PC: For files saved locally on your computer.

	♦ OneDrive: For cloud-saved files.

	♦ Browse: To search for the file manually in your folders.

5.	 Navigate to the folder containing the Excel file.

6.	 Select the file you want to open and click Open.

Method 2: Using File Explorer (Windows)

1.	 Open File Explorer and navigate to the folder where the Excel file is stored.

2.	 Double-click the Excel file (e.g., bank-customer.xlsx). It will open directly 
in the Excel application.

Method 3: Drag and Drop

1.	 Open the Excel application.

2.	 Drag the Excel file from its folder and drop it onto the open Excel window.
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Method 4: From Recent Files

1.	 Open the Excel application.

2.	 In the Home screen of Excel, you’ll see a list of recently opened files. Click 
on the file name to open it.

Method 5: Keyboard Shortcut

1.	 Open Excel and press Ctrl + O to quickly access the Open menu.

2.	 Navigate to the file location and select the desired file.

Exercise Questions

1.	 Navigating and Selecting Data in Excel

Open a new Excel workbook.

	♦ Use the Name Box to navigate to cell H15.

	♦ Select all the data in the range A1:C10 using the mouse.

	♦ Highlight the entire worksheet using a shortcut key.

2.	 Moving Within the Worksheet 
In a pre-filled worksheet:

	♦ Use the scroll bars to navigate to cell Z50.

	♦ Return to cell A1 using a shortcut key.

	♦ Navigate to the last filled cell in the worksheet using the Ctrl + Arrow keys.

3.	 Selecting Cells, Rows, and Columns

Open an existing workbook and perform the following:

	♦ Select the entire row for row 5.

	♦ Highlight columns B to D.

	♦ Select all cells in the range E1:E20 using the Shift key and mouse.

4.	 Selecting Data with Keyboard Shortcuts

In a new worksheet, enter some random data in cells A1:A20.

	♦ Use the Ctrl + Shift + Down Arrow shortcut to select all filled cells in column 
A.
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	♦ Extend the selection to include columns B and C using the Shift + Right 
Arrow shortcut.

	♦ Use Ctrl + A to select all data in the worksheet.

5.	 Opening an Excel File 
Perform the following tasks:

	♦ Open a pre-saved workbook named Sample.xlsx from your system.

	♦ Open a new workbook using the Ctrl + N shortcut.

	♦ Close the newly opened workbook without saving using a keyboard shortcut.

1.1.8 Data Types in Excel 

Excel supports a variety of data types, enabling users to perform different types of 
calculations, manage information, and visualize data efficiently. This session focuses 
on identifying, using, and manipulating these data types.

Different data types in Excel are

1.	 Text (String)

Used for alphanumeric data, such as names, addresses, or any non-numeric information. 
Commonly used for Labels for rows and columns and storing non-numeric information 
like product names or categories.

	♦ Characteristics:
	� Aligns to the left in a cell by default.
	� Can contain letters, numbers, and special characters.
	� Excel does not perform arithmetic operations on text.

	♦ Examples:
	� Names: John Doe
	� IDs: INV12345
	� Messages: “Hello, World!”

 Use the CONCATENATE () or TEXTJOIN () function to combine text values.

2.	 Numbers

Numeric data for arithmetic calculations or quantitative analysis. Commonly used for 
Mathematical computations (e.g., sums, averages) and Charts and data visualization. 

	♦ Characteristics:
	� Aligns to the right in a cell by default.
	� Includes whole numbers, decimals, and scientific notations.
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	♦ Examples:
	� Integer: 123
	� Decimal: 45.67
	� Scientific Notation: 1.23E+4 (represents 12300)

Use the ROUND (), INT (), and MOD () functions for specific numeric operations.

3.	 Date and Time

Represents calendar dates and clock times. Internally stored as numbers and commonly 
used for scheduling, timelines and analyzing data over specific periods. 

	♦ Characteristics:
	� Aligns to the right in a cell by default.
	� Dates and times can be formatted in various ways (e.g., DD/MM/YYYY, 

HH:MM AM/PM).

	♦ Examples:
	� Date: 01/08/2025
	� Time: 14:30 (2:30 PM)
	� Combined Date and Time: 01/08/2025 14:30

Use date functions (=TODAY (), =DATE ()) and time functions (=NOW (), =TIME ()). 
Perform operations like adding days (=A1+7 for a week later).

4.	 Boolean (Logical)

Represents logical values, either TRUE or FALSE. Commonly used in conditional 
formatting and decision-making formulas.

	♦ Characteristics:
	� Often used in logical operations and formulas.
	� Outputs depend on conditions.

	♦ Examples:
	� Logical Test: =A1>100 → Returns TRUE if the value in A1 is greater 

than 100.
	� =AND(A1>50, B1<20) → Returns TRUE if both conditions are met.

Use logical functions like IF (), AND (), and OR () to create dynamic conditions.

5.	 Currency

Numbers formatted as monetary values, including symbols like $, €, ₹. Commonly used 
in budgeting and financial planning and sales and revenue tracking.
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	♦ Characteristics:
	� Allows users to denote prices or financial figures.
	� Includes decimal places for cents/paisa.

	♦ Examples:
	� $123.45
	� ₹5000.00

Use Accounting format for better alignment and presentation.

6.	 Percentage

Represents numbers as fractions of 100. Commonly used in calculating growth rates or 
proportions and displaying survey results.

	♦ Characteristics:
	� Automatically appends a % symbol.
	� Converts decimal values (e.g., 0.5 → 50%).

	♦ Examples:
	� 25% (represents 0.25)
	� 100% (represents 1.00)

Use =B1/A1 to calculate percentages (e.g., percentage increase).

7.	 Logical test

Represents logical values, either TRUE or FALSE.

	♦ Characteristics:
	� Often used in logical operations and formulas.
	� Outputs depend on conditions.

	♦ Examples:
	� Logical Test: =A1>100 → Returns TRUE if the value in A1 is greater 

than 100.
	� =AND(A1>50, B1<20) → Returns TRUE if both conditions are met.

8.	 Custom

Custom Formats

User-defined formats for displaying data in a specific pattern. Commonly used in 
custom date or time formats.

Specialized formats for identifiers or structured data.
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	♦ Characteristics:
	� Does not alter the data itself, only its appearance.

	♦ Examples:
	� Phone Numbers: (123) 456-7890
	� Product Codes: PROD-0001

Access custom formats via Home → Number → Custom.

9.	 Geography & Stocks

	♦ Linked data types introduced in modern Excel.

	♦ Provides real-time information from the internet.

Example:

	♦ Country: India → Includes population, capital, etc.

	♦ Stock: AAPL → Includes price, market cap, etc.

Exercise Questions 

1.	 Activity 1: Identifying Data Types

	♦ Open a new Excel workbook.

	♦ Enter sample data for each data type in individual cells.

	♦ Observe how Excel recognizes and aligns them automatically.

2.	 Activity 2: Formatting Data

	♦ Select cells and apply different data formats (e.g., currency, percentage).

	♦ Use Home → Number ribbon to explore formatting options.

3.	 Activity 3: Working with Dates and Times

	♦ Enter today’s date and current time in separate cells.

	♦ Use date functions like =TODAY () and time functions like =NOW ().

4.	 Activity 4: Boolean Operations

	♦ Create logical conditions using =IF (), =AND (), =OR () formulas.

	♦ Example: =IF(A1>50, TRUE, FALSE)

5.	 Activity 5: Exploring Linked Data Types

	♦ Insert Geography or Stock data types and explore associated information.

	♦ Example: Use the “Data” tab to add these data types.
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1.1.9 Editing Excel Files

Editing in Excel refers to the process of modifying the content or formatting of cells 
within a worksheet to ensure data accuracy, organization, and presentation. This 
may involve updating existing cell entries, correcting errors, or replacing outdated 
information. Additionally, editing encompasses changing the formatting of cells to 
enhance readability and visual appeal, such as adjusting font styles, sizes, colours, or 
applying borders and shading. It also includes inserting or deleting rows, columns, or 
individual cells to restructure the data layout. Excel provides various tools, such as the 
formula bar and right-click context menu, to facilitate efficient editing. Overall, editing 
is a crucial step in managing and analyzing data effectively in Excel.

1.	 Editing Cell Content

Editing cell content in Excel involves making changes to the data or information already 
entered into a cell. This can include correcting mistakes, updating values, or completely 
replacing the content. To edit a cell, you can simply select the cell and either start 
typing to overwrite the existing content or double-click on the cell to make changes 
within it. Alternatively, you can use the formula bar at the top of the worksheet to make 
adjustments.

Excel provides various options for editing, such as using the “Backspace” or “Delete” 
keys to remove unwanted characters or content. You can also copy, cut, and paste data 
from other cells or external sources to update the content efficiently. Additionally, you 
can use built-in features like Find and Replace to locate specific text or numbers and 
replace them across multiple cells. Editing cell content is a fundamental skill that helps 
ensure the accuracy and relevance of the data in your spreadsheet. Different editing 
methods are

	♦ Double-Clicking:
	� Double-click on the cell to activate edit mode.
	� The cursor appears inside the cell, allowing you to modify the content.

	♦ Using the Formula Bar:
	� Select the cell and edit the content directly in the formula bar above the 

worksheet.

	♦ Keyboard Shortcut:
	� Press F2 to activate edit mode for the selected cell.

	♦ Replacing Entire Content:
	� Select the cell and type new content to replace the old one.

2.	 Bulk Editing

Bulk editing in Excel refers to making changes to multiple cells, rows, or columns 
simultaneously, saving time and effort when working with large datasets. This can 
involve applying formatting, modifying content, or implementing formulas across a 
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selected range of cells. For instance, users can quickly fill multiple cells with a specific 
value or formula using the fill handle, or apply formatting such as font styles, colours, 
or conditional formatting to a group of cells. Bulk editing also includes using tools like 
Find and Replace to modify content in multiple cells or applying filters and sorting 
options to reorganize data. Additionally, Excel’s “Paste Special” feature allows users 
to paste specific attributes, such as values, formats, or formulas, across a range. By 
leveraging bulk editing capabilities, users can streamline their workflow and maintain 
consistency in large spreadsheets.

	♦ Find and Replace:
	� Use Ctrl + H to open the Find and Replace dialog box.
	� Enter the value to find and its replacement value.

	♦ Drag to Copy:
	� Click and drag the fill handle (bottom-right corner of the cell) to copy 

content to adjacent cells.

	♦ Editing Formulas:
	� Double-click a cell with a formula to view and edit it.
	� Use Ctrl + [ to trace formula precedents (cells referenced in the formula).

	♦ AutoCorrect:
	� Enable AutoCorrect for common typos via File → Options → 

Proofing → AutoCorrect Options.

	♦ Undo Changes:
	� Press Ctrl + Z to undo the last action.

	♦ Redo Changes:
	� Press Ctrl + Y to redo an undone action.

Exercise questions 

1.	 Open an Excel file and edit the content of a specific cell by changing the text, 
correcting a typo, or updating a numeric value. What happens to the original 
content?

2.	 Use the “Find and Replace” feature to locate all instances of a specific word 
or number in the worksheet and replace them with new values. How does 
this tool simplify bulk editing?

3.	 Clear the content of a cell and compare it with deleting the same cell. How 
do these actions affect the structure of the worksheet?

4.	 Modify the formatting of a cell by changing its font style, size, colour, and 
applying borders. How do these changes enhance the presentation of the 
data?
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5.	 Edit a formula in a cell to include additional operations or references to other 
cells. How do the changes impact the calculated result and the dependent 
cells?

1.1.10 Deleting in Excel

Deleting in Excel involves removing unwanted data, cells, rows, or columns from a 
worksheet to maintain an organized and accurate dataset. Users can delete specific 
content within a cell while keeping the cell itself, or they can delete entire cells, which 
shifts the surrounding data to fill the gap. Deleting rows or columns completely removes 
them from the worksheet, affecting the structure of the data. This can be done using the 
“Delete” option from the context menu or by selecting the rows/columns and pressing 
the “Delete” key on the keyboard. Additionally, Excel allows users to clear only specific 
aspects, such as formats, contents, or comments, without removing the cell. Deleting is 
a crucial step in cleaning up data and ensuring the worksheet is free of unnecessary or 
redundant information.

1.	 Deleting Cell Content

Deleting cells in Excel involves removing specific cells and shifting the surrounding 
data to fill the gap. This can be done by selecting the cells, right-clicking, and choosing 
“Delete,” followed by specifying whether to shift the cells up or left. Unlike clearing 
content, deleting cells affects the structure of the worksheet by adjusting the layout. 
This feature is particularly useful for reorganizing data or eliminating unnecessary cells 
without deleting entire rows or columns.

	♦ Clearing Contents:
	� Select the cell(s) and press Delete on your keyboard to remove the 

content without deleting the cell itself.

	♦ Clearing Specific Elements:
	� Go to Home → Clear and choose:

	� Clear All: Removes everything (content, formatting, and comments).
	� Clear Contents: Removes only the content.
	� Clear Formats: Retains content but removes formatting.
	� Clear Comments and Notes: Deletes only the comments.

2.	 Deleting Rows and Columns

Deleting rows and columns in Excel allows users to remove entire sections of data from 
a worksheet to streamline its structure and organization. This can be done by selecting 
the row or column, right-clicking, and choosing the “Delete” option, or by using the 
“Delete” command in the ribbon. When a row or column is deleted, the surrounding 
data automatically shifts to fill the space, maintaining the continuity of the worksheet. 
Deleting rows and columns is particularly helpful for eliminating unnecessary or 
duplicate data, reorganizing the layout, or preparing the worksheet for analysis or 
presentation.
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	♦ Using the Right-Click Menu:
	� Right-click on a row/column header or selected cell(s) and choose Delete.

	♦ Keyboard Shortcut:
	� Select the row(s) or column(s) and press Ctrl + - (minus key).

	♦ Dialog Box Options (for cells):
	� After selecting cells, right-click and choose Delete:

	� Shift cells left: Moves cells on the right to the left.
	� Shift cells up: Moves cells below upward.
	� Entire row/column: Deletes the selected row or column.

3.	 Deleting Worksheets

Deleting sheets in Excel involves removing an entire worksheet from a workbook. 
Before deleting, Excel may prompt you to confirm the action, as it permanently removes 
all data and formatting in the sheet. This feature is useful for eliminating unnecessary or 
outdated sheets, and helping keep the workbook organized and focused.

	♦ Single Sheet:
	� Right-click the sheet tab and select Delete.

	♦ Multiple Sheets:
	� Hold Ctrl and select multiple sheets, then right-click and choose Delete.

	♦ Warning: Deleting a sheet is permanent, and the action cannot be undone.

	♦ Remove Blank Rows:
	� Use filters to locate blank rows, select them, and press Ctrl + -.

	♦ Delete Without Losing Formatting:
	� Use Clear Contents instead of Delete to retain format

Exercise questions

1.	 Select a cell and delete its content using the “Delete” key. How does this 
action differ from clearing the formatting of the cell?

2.	 Select a range of cells and delete them by shifting the surrounding data either 
up or left. How does this impact the layout of the worksheet?

3.	 Delete an entire row from a dataset. How does the deletion affect the position 
of the remaining rows and any formulas referencing the deleted row?

4.	 Delete an entire column from a worksheet. Observe how the structure of the 
table changes and identify if formulas referencing the deleted column return 
errors.

5.	 Delete a worksheet from a workbook with multiple sheets. Does Excel prompt 
for confirmation? How does this action impact linked data or formulas in 
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other sheets?

1.1.11 Fill Handle

The fill handle in Excel is a powerful tool used to quickly copy and extend data or 
formulas to adjacent cells. It appears as a small square at the bottom-right corner of 
a selected cell or range. By clicking and dragging the fill handle across the desired 
range, users can replicate the content, continue patterns like numbers, dates, or text 
sequences or apply formulas to multiple cells. The fill handle is useful for saving time 
when working with repetitive data or performing calculations across rows or columns. 
It also supports custom lists, allowing users to define and autofill unique patterns or 
sequences.

Uses of the Fill Handle

1.	 Copying Data

	♦ Select a cell containing data.

	♦ Drag the Fill Handle across the desired range (down, up, left, or right) to 
copy the same value or formula.

Fig 1.1.18 Copy the same value using fill handle

In the above example, the bank name for all customers is the same, so we can use the 
fill handle to copy the value ‘SBI.’ In Column K, Row 2, enter ‘SBI,’ select the cell, and 
drag the fill handle down to the last row.

2.	 Extending Data Series

	♦ Numeric Patterns:
	� Enter two or more numbers in consecutive cells to define a pattern (e.g., 

1, 2, 3).
	� Drag the Fill Handle to extend the sequence.

	♦ Date Series:
	� Enter a starting date (e.g., 01/01/2025) and drag the Fill Handle to fill 
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consecutive dates.

	♦ Custom Series:
	� Define custom lists (e.g., “Monday, Tuesday, Wednesday”) via File → 

Options → Advanced → Edit Custom Lists.

Fig 1.1.19 Enter consecutive numbers using fill handle

Filling Formulas:

	♦ Enter a formula in one cell.

	♦ Drag the Fill Handle to copy the formula to adjacent cells while automatically 
updating the cell references.

Fig 1.1.20 Dragging formula 

We can apply the formula to the first column and drag it down to apply it to the entire 
row.

3.	 AutoFill Options

	♦ After using the Fill Handle, click the AutoFill Options button that appears.

	♦ Choose from:
	� Copy Cells: Repeats the original value.
	� Fill Series: Extends a numeric or date series.
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	� Fill Formatting Only: Applies the format but not the content.
	� Fill Without Formatting: Applies the content but not the format.

4.	 Flash Fill

	♦ Recognizes patterns in adjacent columns and fills data accordingly.

	♦ Example: If column A contains FirstName LastName and column B contains 
FirstName, Excel can auto-fill just the first names in column B.

	♦ Shortcut: Use Ctrl + E to apply Flash Fill.

Exercise Questions

1.	 Activity 1: Copying Data

	♦ Enter Hello in cell A1.

	♦ Drag the Fill Handle down to row 10.

	♦ Observe that “Hello” is repeated in cells A1:A10.

2.	 Activity 2: Creating a Number Series

	♦ Enter 1 in A1 and 2 in A2.

	♦ Select both cells, then drag the Fill Handle down to row 10.

	♦ Observe the series generated: 1, 2, 3, ....

3.	 Activity 3: Working with Dates

	♦ Enter 01/01/2025 in B1.

	♦ Drag the Fill Handle down to fill the next 10 rows with consecutive dates.

4.	 Activity 4: Filling Formulas

	♦ Enter =A1*2 in cell C1 (assume column A contains numbers).

	♦ Drag the Fill Handle down to copy the formula to cells C2:C10.

	♦ Verify that Excel updates the references automatically (e.g., =A2*2, =A3*2).

5.	 Activity 5: Flash Fill

	♦ Enter John Smith in A1 and John in B1.

	♦ Type Jane in B2 (assuming Jane Doe is in A2).

	♦ Press Ctrl + E to auto-fill the first names in column B.
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1.1.12 Templates in Excel

Templates in Excel are pre-designed spreadsheets that provide a structured framework for 
various tasks, saving time and effort. They come with predefined formatting, formulas, 
and layouts tailored to specific purposes, such as budgets, invoices, calendars, project 
plans, or data tracking. Excel templates are customizable, allowing users to adapt them 
to their unique needs while retaining the original structure. Built-in templates are readily 
available in Excel, and additional templates can be downloaded online or created from 
scratch. By using templates, users can streamline repetitive tasks, maintain consistency 
in their work, and ensure accuracy in data entry and calculations.

1.	 Types of Templates in Excel

	♦ Built-in Templates:
	� Pre-installed with Excel.
	� Examples: Budget plans, invoices, calendars, expense reports.

	♦ Custom Templates:
	� Created by users to suit specific needs.
	� Example: A unique project tracker for a team.

	♦ Online Templates:
	� Downloadable from Microsoft Office or third-party sources.
	� Accessible via the File → New menu.

2.	 Accessing Templates in Excel

	♦ Using Built-in Templates:
	� Open Excel and go to File → New.
	� Browse the list of available templates.
	� Click on a template to preview it.
	� Select Create to open the template as a new workbook.

	♦ Using Online Templates:
	� Go to File → New.
	� Type keywords (e.g., “Invoice”) in the search bar.
	� Browse results and choose a template.
	� Select Create to use the template.

	♦ Using Custom Templates:
	� Save a spreadsheet as a template:

	� Create your custom layout and design.
	� Go to File → Save As and select Excel Template (*.xltx) as the file 

type.
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	� Save it in the default template folder.
	� Access your saved templates via File → New → Personal.

3.	 Uses of Templates in Excel

	♦ Budgeting:
	� Track monthly expenses, income, and savings.
	� Use formulas for automatic calculations.

	♦ Project Management:
	� Create Gantt charts, to-do lists, or milestone trackers.

	♦ Invoices and Billing:
	� Generate invoices with automatic tax and total calculations.

	♦ Attendance Sheets:
	� Track student or employee attendance with pre-set tables.

	♦ Reports:
	� Format data and charts into professional-grade reports.

Exercise Questions

Activity 1: Using a Built-in Template
1.	 Open Excel and go to File → New.
2.	 Search for the “Personal Monthly Budget” template.
3.	 Fill in sample income and expense data.
4.	 Observe how the totals update automatically.

Activity 2: Downloading an Online Template
1.	 Go to File → New.
2.	 Search for “Invoice” in the search bar.
3.	 Select a template and click Create.
4.	 Enter sample customer details, items, and prices.
5.	 Save the file with the name Sample_Invoice.xlsx.

Activity 3: Creating a Custom Template
1.	 Create a student attendance tracker:
2.	 Add columns for Name, Roll Number, and days of the week.
3.	 Apply borders, shading, and a title.
4.	 Save the file as a template (.xltx).
5.	 Open the template to create a new workbook.
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Experiment 2
Basic Functions and Formulas, 

Formatting and Printing
Discussion

1.2.1 Introduction 

Mastering Excel’s foundational functions and formatting tools is essential for efficient 
data analysis and presentation. Key functions like SUM, AutoSum, AVERAGE, MIN, 
and MAX enable users to perform fundamental calculations, such as totaling values, 
computing averages, and identifying minimum and maximum figures within datasets. 
Understanding cell references including relative, absolute, and mixed references 
- is crucial for creating dynamic formulas that adapt as data changes. Additionally, 
Excel’s formatting features, such as borders, alignment tools, Format Painter, number 
formats, styles, and themes, enhance the visual appeal and readability of spreadsheets. 
Proficiency in these areas ensures that data is not only accurate but also presented in a 
clear and professional manner, facilitating better decision-making and communication.​

1.2.2 Theory

1.2.2.1 Basic Functions in Excel

Excel provides a variety of basic functions that simplify calculations and data analysis. 
Common functions include SUM () for adding values, AVERAGE () for calculating the 
mean, COUNT () for counting cells with numbers, MAX () and MIN () for finding the 
highest and lowest values, and IF () for performing logical tests. These functions make 
it easy to process and analyze data efficiently, helping users perform everyday tasks 
like totaling expenses, calculating averages, or comparing values with ease. Detailed 
explanations are given below:

1.	 SUM Function: Adds all numbers in a specified range.​ 
Syntax: =SUM(number1, [number2], ...)​

	 Example: =SUM(A1:A10) //calculates the total of values from cell A1 to 
A10.​

2.	 AutoSum Feature: A quick method to apply the SUM function.​ Select the 
cell below or to the right of the numbers to sum, then click the “AutoSum” 
button (Σ) on the toolbar. Excel automatically detects the range to sum 
and inserts the formula.   It computes the arithmetic mean of a range.​ 
Syntax: =AVERAGE(number1, [number2], ...)

	 Example: =AVERAGE(B1:B10) //calculates the average of values from cell 
B1 to B10.​
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3.	 MIN Function: Identifies the smallest number in a range. 
Syntax: =MIN(number1, [number2], ...)

	 Example: =MIN(C1:C10) //returns the lowest value between cells C1 and 
C10.​

4.	 MAX Function: Identifies the largest number in a range.​ 
Syntax: =MAX(number1, [number2], ...)​

	 Example: =MAX(D1:D10) //returns the highest value between cells D1 and 
D10.

The basic functions are again categorized into different groups based on their purpose. 
Here are some of the main categories of built-in functions in Excel:

1.2.2.2 Mathematical Functions

Excel provides a wide range of mathematical functions that allow users to perform 
various calculations, from basic arithmetic to more complex mathematical operations. 
These functions are essential for analyzing data, solving equations, and automating 
repetitive calculations. Below are some of the commonly used mathematical functions 
in Excel:

A. Basic Arithmetic Functions:​ In Microsoft Excel, several fundamental functions 
facilitate efficient data analysis and management:

	♦ SUM (): Adds values in a range. 

	 Example: =SUM (A1:A5) calculates the total of cells A1 through A5.

	♦ PRODUCT (): Multiplies values in a range. 

	 Example: =PRODUCT (A1:A3) multiplies the values in cells A1, A2, and 
A3.

	♦ SUBTRACTION: No direct function, but you can subtract values using a 
formula like =A1-A2.

	♦ DIVISION: No direct function, but you can divide values using a formula 
like =A1/A2.

B. Power and Root Functions

	♦ POWER (): Calculates the power of a number. 

	 Example: =POWER (3, 2) returns 9 (3²).

	♦ SQRT (): Returns the square root of a number. 

	 Example: =SQRT (16) returns 4.

36             SGOU - SLM - BSc - DS&A - Essential Excel Skills for Data Analysis



	♦ EXP (): Calculates the exponential value of a number (e raised to the power 
of a number). 

	 Example: =EXP (1) returns approximately 2.718.

C. Rounding Functions

	♦ ROUND (): Rounds a number to a specified number of digits. 

	 Syntax: ROUND(number, num_digits)

In the above syntax, number is the number you want to round. num_digits specifies the 
number of decimal places to round to:

	� A positive value rounds to the specified number of decimal places.
	� Zero rounds to the nearest whole number.
	� A negative value rounds to the nearest multiple of 10, 100, etc. 

	 Example: =ROUND (3.14159, 2) returns 3.14.

	♦ ROUNDUP (): Rounds a number up, away from zero. 

	 Syntax: ROUNDUP(number, num_digits)

In the above syntax, number is the numeric value to be rounded up. num_digits specifies 
the number of decimal places to round up to:

	� A positive value rounds up to the specified number of decimal places.
	� Zero rounds up to the nearest whole number.
	� A negative value rounds up to the nearest multiple of 10, 100, etc.

Note: ROUNDUP() adjusts the number upward, that is it always moves the number up 
to the next possible value at the specified decimal place.

	 Example: =ROUNDUP (3.14, 1) returns 3.2.

	♦ ROUNDDOWN (): Rounds a number down, towards zero. 

	 Syntax: ROUNDDOWN(number, num_digits)

In the above syntax, number is the numeric value to be rounded down. num_digits 
specifies the number of decimal places to round down to:

	� A positive value rounds down to the specified number of decimal places.
	� Zero rounds down to the nearest whole number.
	� A negative value rounds down to the nearest multiple of 10, 100, etc.

Note: Rounding Rule: Always rounds down

	 Example1: =ROUNDDOWN (3.14, 1) returns 3.1.

	 Example2:=ROUNDDOWN (5.99, 1) returns 5.9.
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	♦ INT (): Returns the integer portion of a number, truncating any decimals. 

	 Syntax: INT(number)

where, number is the numeric value to be rounded down to the nearest integer.

	 Example: =INT (3.9) returns 3.

D. Trigonometric Functions

	♦ SIN (), COS (), TAN (): Calculate the sine, cosine, and tangent of an angle 
(in radians). 

	 Example: =SIN (PI ()/2) returns 1.

	♦ ASIN (), ACOS (), ATAN (): Return the arcsine, arccosine, and arctangent 
of a number. 

	 Example: =ASIN (1) returns π/2 (1.57 radians).

	♦ DEGREES (): Converts radians to degrees. 

	 Example: =DEGREES (PI ()) returns 180.

	♦ RADIANS (): Converts degrees to radians. 

	 Example: =RADIANS (180) returns π (3.14). 

E. Logarithmic and Exponential Functions

	♦ LOG (): Returns the logarithm of a number with a specified base. 

	 Example: =LOG (100, 10) returns 2 (log base 10 of 100).

	♦ LN (): Returns the natural logarithm (log base e) of a number. 

	 Example: =LN (2.718) returns approximately 1.

	♦ EXP (): Calculates e raised to the power of a number. 

	 Example: =EXP (2) returns 7.39. 

F. Absolute Value and Sign Functions

	♦ ABS (): Returns the absolute value of a number. 

	 Example: =ABS (-10) returns 10.

	♦ SIGN (): Returns 1 for positive numbers, -1 for negative numbers, and 0 for 
zero. 

	 Example: =SIGN (-10) returns -1.

G. Sum-Based Functions

	♦ SUMIF (): Adds values based on a condition. 
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	 Example: =SUMIF (A1:A10, “>5”) adds all values greater than 5 in the 
range A1 to A10.

	♦ SUMPRODUCT (): Multiplies corresponding elements in arrays and 
returns the sum of those products. 

	 Example: =SUMPRODUCT (A1:A3, B1:B3) multiplies each value in 
A1:A3 with the corresponding value in B1:B3 and sums the results.

H. Data Analysis Functions

	♦ AVERAGE(): The Average function calculates the arithmetic mean of sets 
of numbers. That is the sum of numbers divided by the count of numbers.

Syntax: 

	 =AVERAGE(number1, [number2], …)

Example:

	 =AVERAGE(12,23,11,5,8,10) //will give result as 11.5 as average is calculated 
as  [(12+23+11+5+8+10)/6]

We can also calculate the average by including the range of cells in the equation as

	 =AVERAGE(A1:A6) if the data is ranging from cells A1 to A6

	♦ MEDIAN(): This function is used to calculate the median value.  The 
median indicates the middle value in a given set of numbers after arranging 
them in ascending order. If the total numbers in the set are odd, the middle 
value is returned. If the number of values is even, the average of the two 
middle values is returned.

Syntax: 

	 =MEDIAN(number1, [number2], …)

Example1:

	 =MEDIAN(12,23,11,5,8,10) will return the result as 10.5

First arrange the numbers in ascending order: 5,8,10,11,12,23, find the average of two 
middle numbers.

Example 2:

	 =MEDIAN(12,23,8,5,11)will return the result as 11

First arrange the numbers in ascending order: 5,8,11,12,23 find the middle number

We can also write the range of cells instead of separating numbers by comma

	 =MEDIAN(A1:A6)
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	♦ MODE(): Finds the most frequent number in the set of given numbers. If 
there are more than one value with the same highest frequency, it returns the 
first one found.

Syntax:

	 =MODE(number1, [number2], …)

Example: 

	 =MODE(11,12,11,12,12,10,12) will return the result as 12

 	 =MODE(11,12,11,12,10,10,8) will return the result as 11 even though there are 
11, 12, and 10 are appearing at the same frequency, but 11 is occurring first. Hence the 
result is 11. 

We can also write the range of cells instead of separating numbers by comma

	 =MODE(A1:A6)

	♦ COUNT(): This function counts the number of numeric values in the given 
range of values. This function will not consider blank values, text values, 
and non-numeric data.

Syntax:

	 =COUNT(value1, [value2], …)

Example:

	 =COUNT(12,23,11,5,8,10) will return the result as 6

	 =COUNT(12,23,11,”abc”,8,”*”) will return the result as 4. In this case, the 
function will ignore text value and non-numeric data.

We can also write the range of cells instead of separating numbers by comma

	 =COUNT(A1:A6)

	♦ COUNTA(): This function counts all the non-empty cells in the given range 
of cells. All numbers and text are included while counting. It is useful to 
count the total number of filled cells in the range of data or the dataset.

Syntax:

	 =COUNTA(value1, [value2], …)

Example:

	 =COUNTA(12,23,11, “abc”,8,”*”) will return the result as 6 as it counts text  
and non-numeric values.

We can also write the range of cells instead of separating numbers by comma

	 =COUNTA(A1:A7)
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1.2.2.3 Text Functions in Excel

Excel provides several powerful text functions that help manipulate, format, and 
clean text data. These functions are essential for managing textual data, such as 
names, addresses, and product descriptions, and are widely used in data cleaning and 
preparation. Below are some of the most commonly used text functions in Excel:

i.	 CONCAT () / CONCATENATE (): Combines text from multiple cells into 
one. Useful for merging first and last names, addresses, or other fields.

	 Example: =CONCAT (A1, “ “, B1) combines the values in cells A1 and 
B1 with a space in between.

ii.	 TEXT (): Formats a value and converts it to text. Useful for customizing 
date, time, or number formats.

	 Example: =TEXT (A1, “MM/DD/YYYY”) formats a date in cell A1 as 
“12/31/2025”.

iii.	 LEFT(): Extracts a specific number of characters from the start of a text 
string. Useful for extracting prefixes or codes from strings.

	 Example: =LEFT (A1, 5) returns the first five characters of the text in cell 
A1.

iv.	 RIGHT(): Extracts a specific number of characters from the end of a text 
string. Useful for extracting suffixes or specific trailing information.

	 Example: =RIGHT (A1, 3) returns the last three characters of the text in 
cell A1.

v.	  LEN(): Counts the number of characters in a text string, including spaces. 
Useful for validating or analyzing text lengths.

	 Example: =LEN(A1) returns the length of the text in cell A1.

vi.	 TRIM(): Removes all extra spaces from a text string, leaving only single 
spaces between words. Useful for cleaning text data imported from other 
sources.

	 Example: =TRIM(A1) cleans up unnecessary spaces in cell A1.

vii.	UPPER(): Converts all text to uppercase. Useful for standardizing text.

	 Example: =UPPER(A1) changes “hello” to “HELLO”.

viii.	LOWER(): Converts all text to lowercase. Useful for consistency in case-
sensitive environments.

	 Example: =LOWER(A1) changes “HELLO” to “hello”.
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ix.	 FIND(): Returns the position of a specific character or substring within a 
text string. Useful for locating specific text.

	 Example: =FIND(“e”, A1) returns the position of the first occurrence of 
“e” in cell A1.

x.	 SUBSTITUTE(): Replaces occurrences of a specific text within a string 
with another text. Useful for updating or cleaning up text.

	 Example: =SUBSTITUTE(A1, “old”, “new”) replaces “old” with 
“new” in cell A1.

xi.	 REPLACE(): Replaces part of a text string, starting at a specific position 
and length.

	 Example: =REPLACE(A1, 3, 2, “xy”) replaces two characters 
starting from the third character in cell A1 with “xy”.

1.2.2.4 Logical Functions in Excel:

Logical functions in Excel allow users to test conditions and return specific results 
based on whether the condition is TRUE or FALSE. These functions are essential for 
decision-making, automating tasks, and analyzing data. Here are the commonly used 
logical functions in Excel:

i.	 IF(): The IF function returns one value if a condition is TRUE and another 
value if it is FALSE. Decision-making, such as determining pass/fail, 
eligibility, or categorization.

	 Syntax: =IF(condition, value_if_true, value_if_false)

	 Example: =IF(A1>50, “Pass”, “Fail”) returns “Pass” if the value in 
A1 is greater than 50; otherwise, it returns “Fail.”

ii.	 AND(): The AND function returns TRUE if all specified conditions are 
TRUE; otherwise, it returns FALSE. Evaluating multiple conditions 
simultaneously.

	 Syntax: =AND(condition1, condition2, ...)

	 Example: =AND(A1>50, B1<100) returns TRUE if A1 is greater than 50 
and B1 is less than 100.

iii.	 OR(): The OR function returns TRUE if at least one condition is TRUE; 
otherwise, it returns FALSE. Checking if any one of several conditions is 
met.

	 Syntax: =OR(condition1, condition2, ...)

	 Example: =OR(A1>50, B1<100) returns TRUE if either A1 is greater than 
50 or B1 is less than 100.
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iv.	  NOT(): The NOT function reverses the result of a condition. If the condition 
is TRUE, it returns FALSE, and vice versa. Handling errors like division by 
zero or invalid references gracefully.

	 Syntax: =NOT(condition)

	 Example: =NOT(A1>50) returns TRUE if A1 is not greater than 50.

v.	  XOR(): The XOR function (exclusive OR) returns TRUE if an odd number 
of conditions are TRUE; otherwise, it returns FALSE.

	 Syntax: =XOR(condition1, condition2, ...)

	 Example: =XOR(A1>50, B1<100) returns TRUE if only one of the 
conditions is TRUE.

1.2.2.5 Date and Time Functions

In Excel, date and time functions are widely used for calculations, formatting, and 
analyzing dates and times. Here are some commonly used date and time functions:

 A. Date Functions in Excel

1.	  TODAY(): Returns the current date.

	 Example: If today is January 12, 2025, =TODAY() returns 12/01/2025.

2.	 DATE(year, month, day): Creates a date value from the given year, month 
and day.

	 Example: date =DATE(2025, 1, 12) //returns 12/01/2025.

3.	 YEAR(date): Extracts the year from a date.

	 Example: year =YEAR(“12/01/2025”) //returns 2025.

4.	 MONTH(date): Extracts the month from a date.

	 Example: 4y=MONTH(“12/01/2025”) //returns 1.

5.	 DAY(date): Extracts the day from a date.

	 Example: day =DAY(“12/01/2025”) //returns 12.

B. Time Functions in Excel

1.	NOW(): Returns the current date and time.

Example:

	 If the current time is 1:30 PM on January 12, 2025, 

	 now =NOW() //returns 12/01/2025 13:30.
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2.	TIME(hour, minute, second): Creates a time value from the given 
hour, minute, and second.

Example:

	 time =TIME(13, 30, 0) //returns 1:30 PM.

3.	HOUR(time): Extracts the hour from a time value.

Example:

	 hours =HOUR(“13:30”) //returns 13.

4.	MINUTE(time): Extracts the minute from a time value.

Example:

	 minutes =MINUTE(“13:30”) //returns 30.

5.	SECOND(time): Extracts the second from a time value.

Example:

	 seconds =SECOND(“13:30:45”) returns 45.

Exercise Questions

Question 1: Calculating Total Sales Using SUM

You have the following sales data for a week:​

	♦ Monday: $100​

	♦ Tuesday: $170​

	♦ Wednesday: $180​

	♦ Thursday: $220​

	♦ Friday: $150​

Fig 1.2.1: Total Sales Using SUM
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Question 2: Using AutoSum to Find the Average Score

A student received the following scores in five subjects:​

	♦ Math: 85​

	♦ Science: 90

	♦ English: 78​

	♦ History: 88​

Fig 1.2.2: AutoSum to Find the Average Score

1.2.3 Theory: Formulas in Excel or Calculations across sheets

In Excel, formulas are expressions that perform calculations, manipulate data, and 
return results. They are used to automate calculations and perform various operations 
on the data in your Excel worksheets.

Formulas in Excel consist of a combination of values, cell references, functions, and 
operators. They are written in specific syntax, starting with an equal sign (=), followed 
by the elements that make up the formula.

Here is an overview of the components commonly used in Excel formulas:

	♦ Values: These are specific numbers, text, or dates that you can directly 
include in a formula. For example, “=5+3” or “= “Hello World””

	♦ Cell References: Excel allows you to refer to cells by their column and row 
reference within a formula. Cell references help dynamically include the 
values stored in those cells in your calculations. For example, “=A1+B1” 
adds the values in cells A1 and B1.

	♦ Functions: There are several built-in functions in Excel that carry out 
particular operations or computations. Functions can be used to manipulate 
data, perform mathematical calculations, analyze data, and more. Examples of 
functions include SUM, AVERAGE, IF, COUNT, and many others. Functions 
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are typically written with the function name followed by parentheses that 
may contain additional arguments. For example, “=SUM(A1:A5)” calculates 
the sum of the values in the range A1 to A5.

	♦ Operators: Operators are symbols or characters that perform specific 
operations on values or cell references. They include arithmetic operators (+, 
-, *, /), comparison operators (=, <>, >, <, >=, <=), logical operators (AND, 
OR, NOT), concatenation operator (&), and more. Operators are used to 
define the type of operation you want to perform within a formula.

1.2.3.1 Operators in Excel 

Excel formulas can be as simple as a single value or cell reference, or they can be 
complex, involving multiple values, cell references, functions, and operators. Formulas 
can be entered directly into cells, or they can be used in various functions and features 
throughout Excel to perform calculations, data analysis, conditional formatting, and 
more.

Using formulas in Excel involves the following steps:

	♦ Select the cell where you want the formula result to display.

	♦ Start the formula by typing an equal sign (=). This tells Excel that you are 
entering a formula.

	♦ Enter all the elements of the formula, which can include cell references, 
values, functions, and operators. You can type them directly or use the mouse 
to select cells or functions from the toolbar.

	♦ As you enter the formula, Excel provides suggestions and auto-complete 
options to help you with syntax and function names. You can also refer to 
the Formula Bar at the top of the Excel window to see and edit the formula.

	♦  Press Enter key once you have completed the formula. Excel will calculate 
the formula and display the result in the selected cell.

By using formulas in Excel, you can perform calculations, analyze data, automate tasks, 
and manipulate data efficiently. Operators allow you to perform mathematical calcula-
tions, comparisons, concatenations, and logical operations. Here are the main types of 
operators in Excel: 

A. Arithmetic Operators:

	♦ Addition (+): Adds values together. For example, “=A1 + B1” adds the 
values in cells A1 and B1.

	♦ Subtraction (-): Subtracts one value from another. For example, “=A1 - B1” 
subtracts the value in cell B1 from the value in cell A1.

	♦ Multiplication (*): Multiplies values together. For example, “=A1 * B1” 
multiplies the values in cells A1 and B1.
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	♦ Division (/): Divides one value by another. For example, “=A1 / B1” divides 
the value in cell A1 by the value in cell B1.

	♦ Exponentiation (^): Raises a value to the power of another value. For 
example, “=A1 ^ B1” raises the value in cell A1 to the power of the value 
in cell B1. 

 B. Comparison Operators:

	♦ Equal to (=): Checks if two values are equal. For example, “=A1 = B1” 
returns TRUE if the values in cells A1 and B1 are equal.

	♦ Not equal to (<>): Checks if two values are not equal. For example, “=A1 
<> B1” returns TRUE if the values in cells A1 and B1 are not equal.

	♦ Greater than (>): Checks if one value is greater than another value. For 
example, “=A1 > B1” returns TRUE if the value in cell A1 is greater than 
the value in cell B1.

	♦ Less than (<): Checks if one value is less than another value. For example, 
“=A1 < B1” returns TRUE if the value in cell A1 is less than the value in 
cell B1.

	♦ Greater than or equal to (>=): Checks if one value is greater than or equal 
to another value.

	♦ Less than or equal to (<=): Checks if one value is less than or equal to 
another value.

 C. Concatenation Operator:

	♦ Ampersand (&): Joins two or more text strings together. For example, 
“=A1 & “ “ & B1” concatenates the values in cells A1 and B1 with a space 
in between.

D. Logical Operators:

	♦ AND: Checks if all specified conditions are TRUE.

	♦ OR: Checks if at least one of the specified conditions is TRUE.

	♦ NOT: Negates the logical value of a condition.

These operators, when combined with values, cell references, and functions, allow 
you to create formulas that perform calculations, comparisons, text manipulations, and 
logical operations in Excel.

1.2.3.2 Entering formulas in Excel
To enter a formula in Excel, follow these steps:

	♦ Select the cell where you want to enter the formula.

	♦ Begin the formula by typing the equal sign (=). This means that you are 
entering a formula.
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	♦ Enter the formula using cell references, operators, and functions. For 
example, to add the values in cells A1 and B1, you can enter “=A1+B1”.

	♦ Use parentheses or round brackets ( ) to control the order of calculations if 
needed. For example, “(A1+B1)*C1” will add the values in cells A1 and B1, 
and then multiply the result by the value in cell C1.

	♦ Press Enter to complete the formula. Excel will calculate the result based on 
the formula you entered and display it in the selected cell.

Fig 1.2.3: Entering formula in Excel

You can also use the Insert Function button (fx) on the formula bar to access a list of 
built-in functions and easily insert them into your formula (Refer to Fig 1.2.1). Simply 
click on the Insert Function button, select the function you want to use, and follow the 
prompts to enter the necessary arguments. The detailed explanation and usage of differ-
ent functions are given in subsequent chapters.

From our above example figure 1.2.1 bank details of a customer, we can calculate 
monthly interest payable for customers who have taken a loan. 
The formula to calculate the monthly interest is:

A.	 Steps to Implement in Excel

1.	 Add a New Column:Add a column titled “Monthly Interest Payable (₹)” 
next to the Interest Rate column.

2.	 Enter the Formula:For example, if the loan amount is in column G and the 
interest rate is in column H. In the first row of the new column I (say row 2), enter: 
 
		  = (G2 * H2) / (100 * 12)

48             SGOU - SLM - BSc - DS&A - Essential Excel Skills for Data Analysis



Fig 1.2.4: Entering formula

3.	 Press enter

Fig 1.2.5: Press enter
4.	 Drag the Formula Down: Copy the formula to all rows in the column.

Fig 1.2.6: Calculating values in all columns after dragging
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5.	 Result: Excel will calculate the monthly interest payable for each customer.

Fig 1.2.7: Result of entering formula

The same can be done using the fx option and using formula ribbon in Excel without 
directly typing the formula into the cell.

Steps to Calculate Monthly Interest Payable Using the fx Option

1.	 Select the Cell for Calculation:

	♦ Click on the cell where you want to display the Monthly Interest Payable I.

2.	 Click on the fx Button:

	♦ Look for the fx button (Function Wizard) next to the formula bar. Click on it.

3.	 Choose a Function:

	♦ In the Insert Function dialog box:
	� Select Math & Trig or All in the “Or select a category” dropdown.
	� Choose the function PRODUCT or MULTIPLY (to calculate the 

product of numbers).

4.	 Enter the Arguments for the Formula:

	♦ The formula for monthly interest payable is: (Loan Amount × Interest Rate) 
÷ 100 ÷ 12

	♦ Input the arguments:
	� For Loan Amount, select the respective cell G
	� For Interest Rate, select the respective cell I. Remember, if the 

percentage format isn’t applied, divide it by 100 here.
	� Use / (divide) for dividing the product by 12 × 100 in subsequent steps.
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5.	 Apply the Formula:

	♦ Click OK, and the calculated monthly interest will appear in the selected 
cell.

B.  Using the Formula Ribbon: You can also use the Formula Ribbon to create the 
same calculation interactively:

1.	 Go to the Formula Ribbon:

	♦ Click on the Formulas tab in the Excel ribbon.

2.	 Insert Function:

	♦ Click on Insert Function on the left-hand side.

3.	 Choose the PRODUCT Function:

	♦ From the dialog box, select PRODUCT to multiply the loan amount and 
interest rate.

4.	 Complete the Formula:

	♦ After calculating the product, divide it using / by 100 × 12 directly in the 
formula bar.

5.	 Drag Down the Formula:

	♦ Use the fill handle to copy the formula down for all rows.

Exercise Questions

Question 1: Round a set of numerical values to the nearest integer.

Fig 1.2.8: Round a set of numerical values

51          SGOU - SLM  - BSc - DS&A - Essential Excel Skills for Data Analysis



Question 2: Combine text from multiple cells into one (Concatenating Text Strings ).

1.2.4 Formatting in Excel

Formatting cells, rows, and columns in Excel is a crucial aspect of data presentation 
and customization. By applying formatting options, you can enhance the visual 
appearance of your data, emphasize important information, and make it more readable 
and professional. Excel Cell can hold different types of data like Numbers, Currency, 
Dates, etc. The various cell formats are as follows;

Fig 1.2.9: Examples of cell formats

	♦ General: The default cell format that displays the cell content as it is.

	♦ Number: Formats the cell content as a number with appropriate separators.

	♦  Currency: Formats the cell content as currency, including the currency sign.

	♦ Accounting: Similar to the currency format, used specifically for accounting 
purposes.

	♦ Date: Formats the cell content as a date, with various date formats available.

	♦ Time: Formats the cell content as a time, with different time formats to 
choose from.

	♦ Percentage: Formats the cell content as a percentage with decimal places.

	♦ Fraction: Formats the cell content as a fraction, such as 1/4 or 1/2.

	♦ Scientific: Formats the cell content in scientific notation, such as 5.6E+01.

	♦  Text: Treats the cell content as normal text without applying any formatting.

	♦ Special: Provides special formats for specific data types, such as zip codes 
or phone numbers.

	♦ Custom: Allows you to create a custom format for the cell content based on 
your specific requirements.

To access the formatting options for cells, rows, and columns in Excel, follow these 
steps:
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Fig 1.2.10: Formatting cells

	♦  Select the cell(s), row(s), or column(s) that you want to format. You can do 
this by clicking and dragging the mouse cursor over the desired cells, rows, 
or columns, or by clicking on a cell and then holding down the Shift key 
while selecting additional cells, rows, or columns.

	♦ Once the desired cells, rows, or columns are selected, you can access the 
formatting options through various methods:

	� Format Cells Dialog Box: Right-click on the selected cells, rows, or 
columns and choose “Format Cells” from the context menu (Refer to Fig 
1.1.16). Alternatively, you can go to the Home tab in the Excel ribbon, 
click on the “Format” drop-down arrow in the Cells group, and select 
“Format Cells.” (Refer Fig 1.2.7)

	� Ribbon Options: In the Home tab of the Excel ribbon, you will find 
different formatting options in the Cells group. These options include 
Font, Alignment, Number Format, Cell Styles, and more. Click on the 
appropriate button for the formatting option you want to apply. (Refer to 
Fig 1.2.7)

	� Shortcut Menus: Right-click on the selected cells, rows, or columns to 
open a shortcut menu. The options in the menu will depend on the type 
of selection, but you can find formatting options such as Format Cells, 
Insert, Delete, and more. (Refer to Fig 1.2.6)

	� Keyboard Shortcuts: Excel also provides keyboard shortcuts for 
formatting. For example, pressing Ctrl+1 opens the Format Cells dialog 
box, Ctrl+B applies bold formatting, Ctrl+I apply italic formatting, and 
Ctrl+U underlines the text.

Once you have accessed the formatting options, you can modify various aspects of the 
selected cells, rows, or columns, such as font style, font size, font colour, cell borders, 
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cell background colour, number formatting, alignment, and more. Make the desired 
changes in the formatting options dialog box or ribbon, and then click OK or apply the 
formatting button to confirm the changes.

By using these methods, you can easily access and apply formatting options to cells, 
rows, and columns in Excel, allowing you to customize the appearance and style of your 
data. Excel provides a range of formatting tools that allow you to customize the appear-
ance of your data. These formatting options help you improve readability, emphasize 
important information, and create a visually organized worksheet. Here are some of the 
key formatting tools available in Excel:

Fig 1.2.11: Options in formatting of cells

Here’s an overview of the main formatting options available in Excel:

1.2.4.1 Types of Formatting

1.	 Font Formatting

	♦ Font Style: You can change the font type (e.g., Arial, Times New Roman) to 
improve the readability and design of the worksheet.

	♦ Font Size: Adjusting the font size allows you to make important information 
more prominent or fit more data into a cell.

	♦ Font Color: Use different colors for text to make certain data stand out or 
categorize information visually.

	♦ Bold, Italic, Underline: Apply bold for emphasis, italics for special data, or 
underline for headings or labels.
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	♦ Changing Font or Style: Use the Home tab to adjust font type, size, color, 
and cell alignment.

Fig 1.2.12 font formatting

2.	 Number Formatting

	♦ Currency: Use currency formatting to display numbers with a currency 
symbol (e.g., $1,000.00).

	♦ Percentage: Convert decimal numbers into percentages (e.g., 0.25 becomes 
25%).

	♦ Date and Time: Format cells to display dates (e.g., DD/MM/YYYY) or 
time (e.g., 2:30 PM), with various styles available.

	♦ Decimal Places: Adjust the number of decimal places shown for numerical 
data for greater precision or simpler display.

Format cells as currency, percentages, or dates using the Number group in the Home 
tab.

3.	  Alignment

	♦ Horizontal and Vertical Alignment: Control the alignment of text or 
numbers within a cell, such as left, center, or right alignment, and top, 
middle, or bottom alignment.

	♦ Text Wrap: If the text is too long for a cell, the “wrap text” feature ensures 
the text continues on multiple lines within the same cell.

	♦ Merge Cells: Combine multiple adjacent cells into one larger cell, often 
used for headers or titles that span across several columns or rows.

4.	 Borders and Shading

	♦ Borders: Apply borders around cells or ranges to define and separate data. 
You can customize border styles (e.g., thick, dotted, or dashed) and apply 
them to individual sides of a cell.
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	♦ Cell Shading (Fill Color): Add background colors to cells to highlight or 
group data. This can help make certain sections stand out, like totals or 
headers.Use Home → Borders to apply or remove borders around cells.

5.	 Conditional Formatting

	♦ Highlight Cells Based on Criteria: Conditional formatting allows you to 
automatically apply specific formatting (e.g., color or font change) to cells 
based on their values. For example, you can highlight cells with values 
greater than 100, or apply a color scale to indicate higher or lower values.

	♦ Data Bars and Color Scales: Visual indicators like data bars (colored 
bars within cells) or color scales (gradient colors based on values) provide 
a quick way to analyze trends and data patterns. Highlight cells based on 
specific criteria (e.g., values greater than 100). Go to Home → Conditional 
Formatting.

6.	 Text Control and Orientation

	♦ Text Orientation: Rotate text in a cell to any desired angle, useful for fitting 
text into narrow columns or for creating unique header layouts.

	♦ Shrink to Fit: This option automatically reduces the font size to fit all the 
content within a cell without overflowing.

7.	 Cell Styles

	♦ Predefined Styles: Excel provides built-in cell styles that combine various 
formatting elements (font, color, borders) to quickly apply consistent 
formatting across your spreadsheet. You can use these styles for headings, 
titles, or emphasized data.

8.	 Custom Formatting

	♦ Excel also allows you to create custom number formats that adjust how data 
appears in a cell. For example, you can format a number to display with 
leading zeros, or even show text before or after numeric values.

9.	 Printing in Excel 

Printing in Excel is a crucial aspect of sharing and presenting data, providing an easily 
shareable format for your spreadsheet. Whether you need a hard copy or a digital 
representation in the form of a PDF, understanding the printing process is essential for 
ensuring that your data is effectively communicated. Excel provides a range of features 
and settings that allow you to customize the printout, controlling everything from layout 
and orientation to the inclusion of specific elements like headers, footers, and gridlines.

Printing in Excel involves configuring various settings to ensure that the data is presented 
on paper or as a PDF in a way that is both visually appealing and functionally effective. 
Let us now learn how to print sheet in Excel:
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i.	 Page Layout: Before printing, it is essential to consider the page layout. 
Decide whether you want to print in portrait (vertical) or landscape 
(horizontal) orientation. You can set this in the “Page Layout” tab.

ii.	 Size and Margins: Adjust the page size and margins using the “Size” and 
“Margins” options in the “Page Layout” tab. This step ensures that your 
content fits well on the printed page.

iii.	 Print Titles: If specific rows or columns need to repeat on each printed 
page, such as headers, use the “Print Titles” command. Go to the “Page 
Layout” tab, click on “Print Titles,” and set the rows or columns to repeat.

iv.	 Print Area: Define a specific print area to include only the selected range 
in your worksheet. Select the range you want to print, go to the “Page 
Layout” tab, and click on “Print Area,” then select “Set Print Area.”

v.	 Print Preview: Before printing, use the “Print Preview” option to see 
how your document will look. Click on “File” and then select “Print.” The 
right panel will show a preview of your document, allowing you to make 
adjustments if needed.

vi.	 Page Breaks: Adjust page breaks to control where Excel starts a new page. 
Go to the “View” tab and select “Page Break Preview.” Drag the page break 
lines to adjust as necessary.

vii.	 Headers and Footers: Customize headers and footers to add information 
such as page numbers, file name, and date. Go to the “Insert” tab and select 
“Header & Footer.” Add elements as needed for your document.

viii.	 Scaling Options: Adjust the size of the printout using scaling options. In 
the “Print” menu, go to “Settings” and choose options like “Fit Sheet on 
One Page” to optimize the document for printing.

ix.	 Print Settings: Configure additional print settings for quality and speed. 
In the “Print” menu, go to “Settings” and select the desired options, such 
as print quality and paper type. Figure 1.2.10 depicted as Printing in Excel.
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Fig 1.2.13: Printing in Excel

x.	 Print to PDF: Save your Excel file as a PDF for easy sharing and viewing. 
In the “File” menu, choose “Save As,” select PDF as the format, and save 
your document.

xi.	 Print: Once you have configured your settings, click on the “Print” button. 
Choose the printer or print to PDF, and click “Print.”

 By following these steps, you can optimise your Excel printouts, ensuring that they are 
both visually appealing and convey the necessary information effectively.

10. Freeze Panes

The “Freeze Panes” feature is a tool for keeping specific rows and columns visible 
while scrolling through large sets of data. It is useful when you want to keep headers or 
labels in view, providing context as you navigate through your spreadsheet. Let us see 
how to use the option in detail. The “Freeze Panes” feature, is located in the “View” 
menu under the Ribbon as shown in the figure given below. The Freeze Panes feature is 
particularly useful when dealing with extensive datasets where headers or labels need 
to remain in view for context.
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Fig 1.2.14: Freeze Panes

 The “Freeze Panes” feature in Excel allows you to lock specific rows or columns, 
making them always visible while scrolling through large datasets. There are three main 
options under “Freeze Panes,” each serving a different purpose as shown in the figure 
above. They are:

1.	 Freeze Panes: The “Freeze Panes” option in Excel is a powerful feature 
that allows you to lock both rows and columns based on the cell you have 
selected. This means that the rows above and the columns to the left of the 
chosen cell will remain visible while scrolling through a large dataset. It is 
particularly useful when you want to keep both row and column headers in 
view for constant reference.

2.	 Freeze Top Row: “Freeze Top Row” is a specific option under “Freeze 
Panes” that focuses on locking only the top row of a worksheet. By selecting 
any cell in the row below the one you want to freeze and choosing this 
option, you ensure that the top row stays fixed at the top of the worksheet. 
This is beneficial when dealing with datasets where the header row provides 
essential information that needs to be visible at all times.

3.	 Freeze First Column: The “Freeze First Column” option in Excel is 
designed to lock only the first column of a worksheet. By selecting any cell 
in the column to the right of the one you want to freeze and choosing this 
option, you ensure that the first column remains visible on the left side of the 
worksheet. This is particularly helpful when dealing with datasets where the 
first column contains labels or identifiers crucial for understanding the data.

These three options, collectively known as “Freeze Panes,” enhance the user experience 
when working with extensive datasets by providing a way to keep specific rows or 
columns visible while navigating through the data.
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The steps to use the freeze pane option is as follows:

1.	 Select the Cell Below and to the Right:

	♦ Click on the cell below the row(s) you want to freeze.

	♦ Click on the cell to the right of the column(s) you want to freeze.

2.	 Access the “Freeze Panes” Option:

	♦ Go to the “View” tab on the ribbon.

3.	 Freeze Panes Options:

	♦ In the “Window” group, find and click on “Freeze Panes.”

	♦ You have three options:
	� Freeze Panes: Freezes both rows and columns based on the cell you 

selected.
	� Freeze Top Row: Only the top row remains visible while scrolling.
	� Freeze First Column: Only the first column remains visible while 

scrolling.

4.	 Unfreeze Panes:

	♦ If you want to remove the frozen panes, go back to the “Freeze Panes” option 
and choose “Unfreeze Panes.” 

Exercise Questions

Question 1: Given a dataset, apply borders around each cell and shade the header row 
with a light gray color.​

Fig 1.2.15: Apply borders around each cell and shade the header row 

Question 2: Format a column of sales to display as currency with two decimal places.
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Fig 1.2.16: Format a column of sales to display as currency

1.2.5 Cell Reference in Excel

A cell reference is a way to identify and refer to a specific cell or range of cells within a 
worksheet. It is used in formulas, functions, and other operations to perform calculations, 
manipulate data, and retrieve values from cells. The cell reference is a combination of 
column letter and the row number; the two components uniquely identify a cell within 
the worksheet. For example, the cell reference “A1” refers to the cell in column A and 
row 1. There are three types of cell references in Excel:

1.	 Relative Cell Reference

 A relative cell reference adjusts when copied or filled to other cells. For example, if 
you have a formula “=A1+B1” in cell C1 and copy it to cell C2, the formula in C2 will 
automatically adjust to “=A2+B2”. The references A1 and B1 change relative to the 
new position of the formula.

2.	 Absolute Cell Reference

An absolute cell reference remains fixed when copied or filled to other cells. To create 
an absolute reference, you add a dollar sign ($) before the column letter and/or row 
number. For example, the formula “=A$1+B$1” will always refer to cell A1 and B1, 
regardless of the new position of the formula.

3.	 Mixed Cell Reference

A mixed cell reference combines aspects of both absolute and relative references. You 
can fix either the column or the row while allowing the other part to adjust when copied. 
For example, the formula “=A$1+B2” will always refer to cell A1, but the row reference 
adjusts to B2 when copied to other cells.
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Cell references can be used in various ways in Excel. They are primarily used in 
formulas and functions to perform calculations based on the values in different cells. By 
referencing cells, you can create dynamic and flexible formulas that update automatically 
when the referenced cells change. This allows you to perform complex calculations, 
analyze data, and create dynamic reports and dashboards within your Excel worksheets.

Cell references are an essential aspect of Excel because they provide flexibility, 
automation, and dynamic capabilities in various spreadsheet tasks. Here are some key 
reasons why we use cell references in Excel:

	♦ Perform Calculations: Cell references allow us to perform calculations and 
mathematical operations in Excel. By referencing cells containing values or 
formulas, we can create complex formulas that dynamically update based on 
the values in the referenced cells. This enables us to automate calculations 
and perform calculations across multiple cells or ranges.

	♦ Dynamic Data Analysis: Cell references are crucial for data analysis in 
Excel. By referencing cells or ranges of data, we can perform various analysis 
operations such as sorting, filtering, conditional formatting, and creating 
charts. Cell references enable us to analyze and manipulate data dynamically, 
making it easier to derive insights and make informed decisions.

	♦ Report Generation: Cell references are widely used in creating reports in 
Excel. By referencing cells containing data, we can generate dynamic reports 
that update automatically as the underlying data changes. Cell references 
allow us to pull data from different cells or ranges, perform calculations, and 
present the information in a summarised or organised format. This makes it 
easier to generate accurate and up-to-date reports.

	♦ Data Validation: Cell references play a vital role in data validation in Excel. 
By referencing cells, we can define rules and conditions that restrict the type 
of data or values that can be entered. Cell references enable us to validate 
and verify data entered by users, ensuring data accuracy, consistency, and 
adherence to predefined rules.

	♦ Conditional Formatting: Cell references are used extensively in conditional 
formatting in Excel. By referencing cells, we can define formatting rules that 
dynamically change the appearance of cells based on specified conditions. 
Cell references allow us to highlight data, apply color schemes, icon sets, or 
data bars based on the values or conditions in the referenced cells. This helps 
in visualising data, identifying patterns, and drawing attention to important 
information.

	♦ Data Integration: Cell references are used when integrating Excel with 
other applications or data sources. By referencing cells in formulas, we can 
retrieve or link data from external sources, such as databases, web services, 
or other Excel workbooks. Cell references enable us to establish connections 
and pull data from external sources into our Excel worksheets, allowing for 
data consolidation and analysis.

Overall, cell references in Excel provide the ability to create dynamic and 
automated spreadsheets, perform calculations, analyze data, generate reports, and 
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integrate with external sources. They enhance the efficiency, accuracy, and flexibility 
of our Excel tasks and allow for efficient data manipulation and analysis.

To create a relative cell reference in Excel, you simply enter the cell 
reference without any dollar signs ($). Here is how you can do it:

●	 Select the cell where you want to enter the formula or value that contains the 
relative cell reference.

●	 Begin typing the formula or value in the cell, starting with an equal sign (=) 
to indicate that you are entering a formula.

●	 To create a relative cell reference, enter the column letter followed by the 
row number of the cell. For example, to reference cell A1, you would enter 
“A1”.

●	 After entering the relative cell reference, you can continue entering the rest 
of the formula or value.

●	 Press Enter to confirm the formula or value, and Excel will use the relative 
cell reference.

When you copy or fill a formula or value that contains a relative cell reference to other 
cells, the referenced column(s) and row(s) will adjust automatically relative to the 
new position of the formula. For example, if you copy a formula with a relative cell 
reference from cell A1 to cell B1, the reference will adjust to B1. Similarly, if you copy 
the formula to cell A2, the reference will adjust to A2.

Relative cell references are useful when you want the formula or value to adapt to 
different locations in the worksheet. They allow you to perform calculations based on 
the relative position of cells, making it easier to apply the same logic to multiple cells or 
ranges. To explain relative cell reference let us use a data sheet as given in Fig 1.2.17. 

Fig 1.2.17: Quarterwise_Sales Dataset
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So in order to find the total sales we can use multiple options like either using “= sign” 
or “using fx insert option” or “ Alt+ = sign and then enter option”. Then the result will 
be as shown in Fig 1.2.18.

Fig 1.2.18: Finding total sales in one row

Here we found total sales for one person, so to find the total sales for rest of the salesmen 
we can use the drag and drop option or auto fill option.

When we do this the sum of all the quarters will be added to the total sales column and 
shown as in Fig 1.2.18

Fig 1.2.19: Total sales of all salesmen

This is relative cell reference. By default, all cell references are relative cell references.

To create an absolute cell reference in Excel, you need to add a dollar sign ($) before 
the column letter and/or row number of the cell reference. Here is how you can do it:

	♦ Select the cell where you want to enter the formula or value that contains the 
absolute cell reference.

	♦ Begin typing the formula or value in the cell, starting with an equal sign (=) 
to indicate that you are entering a formula.

	♦ To create an absolute cell reference, you need to add a dollar sign ($) before 
the column letter and/or row number of the cell reference. Here are the 
different ways to use absolute cell references:

	♦ To make both the column and row absolute, place a dollar sign before 
both the column letter and row number. For example, to create an absolute 
reference to cell A1, you would enter “$A$1”.
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	♦ To make only the column absolute, place a dollar sign before the column 
letter but not before the row number. For example, to create an absolute 
reference to column A but allow the row number to adjust, you would enter 
“$A1”.

	♦  To make only the row absolute, place a dollar sign before the row number 
but not before the column letter. For example, to create an absolute reference 
to row 1 but allow the column letter to adjust, you would enter “A$1”.

	♦ After adding the dollar sign(s) to the appropriate location(s), you can 
continue entering the rest of the formula or value.

	♦ Press Enter to confirm the formula or value, and Excel will use the absolute 
cell reference.

When you copy or fill a formula or value that contains an absolute cell reference to 
other cells, the referenced column(s) and/or row(s) will remain fixed, and they will not 
adjust relative to the new position of the formula. This allows you to refer to specific 
cells or ranges consistently in your formulas, even when copied to different locations 
in the worksheet.

Let us work on the same Quarterwise_Sales Dataset for understanding absolute cell 
reference. For that we have taken the total sales in that year and added one more column 
titled Total Sales %. It is as shown in Fig 1.2.14

Fig 1.2.20 : Quarterwise_Sales Dataset with Total Sales % 

To find the total sales % of Ravi we will use the formula Total sales of Ravi divided by 
Grand total. And then choose percentage from the Number ribbon.  The result will be 
as shown in Fig 1.2.15.
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Fig 1.2.21: Sales % of Ravi

 If we try to drag and drop or auto-fill the result will be as shown in Fig 1.2.16. This is 
where we use an absolute cell reference.

Fig 1.2.22: Auto-fill

Exercise Questions

Question 1: In a worksheet, enter the numbers 10, 20, and 30 in cells A1, A2, and A3, 
respectively. In cell B1, write a formula that multiplies the value in column A by 2. 
Copy this formula down to cells B2 and B3. Observe how the formula adjusts for each 
row (By using Relative Cell References).

Fig 1.2.23: A formula that multiplies the value in column A by 2
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Experiment Questions
1.	 Apply different font styles, sizes, and colors to a range of cells containing 

text data. How does altering the font and color improve the readability and 
presentation of the data?

2.	 Format a cell containing a numeric value to display it as currency, percentage, 
and date. What happens to the value in the cell, and how does it affect the 
overall appearance of the data?

3.	 Set up conditional formatting to highlight cells that meet specific criteria, 
such as values greater than 100. How does this formatting help in identifying 
trends or outliers in the dataset?

4.	 Align the text within a cell to the left, right, and center. Then, merge multiple 
cells to create a title header. How does alignment and merging affect the 
layout and appearance of the worksheet?

5.	 Use the SUM and AVERAGE functions to compute the total and average of 
a dataset. Also find the lowest and highest values in datasets.
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Experiment 3
Dating Sorting

Discussion

1.3.1 Introduction

Sorting is a key aspect of data organization that helps structure information in 
a meaningful way. It makes it easier to interpret and analyze. It involves arranging 
data in a particular sequence, such as ascending or descending order, based on text, 
numbers, or dates. Excel provides robust sorting options that allow you to sort by one 
or more columns, making it a powerful tool for handling extensive datasets. Whether 
you’re prioritizing sales numbers, categorizing client information, or evaluating survey 
responses, sorting helps present your data in a clear and structured format, laying the 
foundation for insightful analysis.

1.3.2 Theory

1.3.2.1 Types of Data Sorting

1. Sorting Data in a Single Column

Sorting data in a single column is one of the simplest and most common tasks in Excel. 
This allows you to organize the values within a single column either in ascending order 
(A to Z or smallest to largest) or descending order (Z to A or largest to smallest). Sorting 
a single column is particularly useful for tasks like arranging names alphabetically, 
ranking sales figures, or organizing dates chronologically.

Steps to Sort a Single Column in Excel:

1.	 Select the Column to Be Sorted: Highlight the column you want to sort by 
clicking on the column header (e.g., “A”).

2.	 Access the Sorting Option:

	♦ Navigate to the Data tab in the toolbar.

	♦ Click on Sort A to Z for ascending order or Sort Z to A for descending order.

3.	 Confirm Sorting: 
If Excel detects adjacent data, it will prompt you to either:



	♦ Expand the selection to sort all related data (e.g., rows linked to the column).

	♦ Continue with the current selection to sort only the highlighted column.

4.	 View the Results: The data in the column will be rearranged based on the 
selected sorting order.

Example: Sorting Product Prices

Original data

Fig.1.3.1. Original data before sorting 

Ascending Sort (Smallest to Largest)

Fig.1.3.2. Confirm Sorting
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Fig.1.3.3 Data sorted in Ascending order 

When sorting a single column, Excel checks for data in adjacent columns and offers 
two options:

1.	 Expand the Selection: Sorts the entire dataset, ensuring rows remain 
intact and relationships between columns are preserved.

2.	 Continue with the Current Selection: Sorts only the selected column, 
which may misalign data in adjacent columns, leading to potential errors. 
Use this option with care.

2. Sorting Data by Multiple Columns

Sorting data is a fundamental skill in data analysis, allowing you to organize information 
for better understanding and decision-making. In Excel, sorting by multiple columns 
helps you arrange your data based on more than one criterion, such as sorting by region 
and then by sales within each region. This ensures data is structured logically, making 
insights easier to derive.
Steps to Sort Data by Multiple Columns

	♦ Open your Excel file containing the dataset.  For example, consider the 
following dataset of Sales representatives:

Fig.1.3.4 Sales Representatives dataset
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	♦ Click anywhere within the data range, or select the entire table (including 
headers).

	♦ Make sure all rows and columns you want to sort are included.

	♦ Go to the Data tab in Excel.

	♦ Click on Sort in the “Sort & Filter” group.

	♦ In the Sort dialog box, perform the following:
	� First Level:

	� Under “Column,” select Region.
	� Under “Sort On,” choose Cell Values.
	� Under “Order,” select A to Z.

	� Second Level:
	� Click Add Level.
	� Under “Column,” select Sales.
	� Under “Order,” select Largest to Smallest.

Fig.1.3.5 Adding levels in Sort dialog box

	♦ Click OK. Excel will sort the data as follows:

Fig.1.3.6 Sales representatives data after sorting
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3. Case-Sensitive Sorting

Excel provides the option to differentiate between uppercase and lowercase letters 
during sorting, which is particularly useful in specialized data formats.

How to Use:

Go to Sort Options in the Sort dialog box.

Check the box for Case Sensitive.

Apply the desired sorting order.

4. Sorting by Cell or Font Color

Excel allows you to sort data by cell color or font color, a handy feature for datasets that 
rely on visual cues.

How to Use:

1.	 Select your data range and open the Sort dialog box.

2.	 Choose the column to sort by and select Cell Color or Font Color in the 
Sort On dropdown.

3.	 Specify the color and sorting preference (on top or bottom).

Lab Exercise 1

1.	 Sort a dataset of product names and prices in descending order of price. 
Make sure to preserve the relationship between product names and their 
corresponding prices.

Lab Exercise 2

2.	 You have a list of sales orders with dates and amounts. Sort the data by date in 
ascending order (oldest to newest), and then by order amount in descending 
order (largest to smallest).
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1.3.2 Data Filtering

Data Filtering is an essential step in data analysis, especially when working with large 
datasets. Filters allow you to narrow down a dataset by displaying only rows that meet 
certain criteria. The rest of the data remains hidden but is not deleted. You can filter data 
based on:

1.	 Specific values
2.	 Conditions (e.g., greater than, less than)
3.	 Text, numbers, or dates

1.3.2.1 Types of Data Filtering

1.	 Filtering based on Specific Values

You can filter data to show only rows that match a particular value in a column. This 
is especially useful when you want to isolate specific entries, like a certain region, 
product, or category.

Example Dataset: Sales record

Fig.1.3.7 Sales Record
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Objective: Filter Data to Display Relevant Information

You might want to:
1.	 Show only sales from the East region.
2.	 Display records where Sales exceed $3000.
3.	 List sales of Laptops only.

Step-by-Step Guide to Applying Filters

1.	 Enable Filters
	� Select the dataset, including headers.
	� Go to the Data tab in the Excel ribbon.
	� Click on the Filter button. Small drop-down arrows will appear in each 

header cell.

2.	 Apply a Filter for a Single Column

	 Filter by Region:
	� Click the drop-down arrow in the Region column.
	� Uncheck Select All, then check East.
	� Click OK.

Fig.1.3.8 Filter by Region
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Fig.1.3.9. Data after filtering

Result: Only rows where the Region is “East” are displayed.

3.	 Apply Multiple Filters

	 Filter by Region and Sales Amount:

	♦ First, filter Region to display only “East” (as above).

	♦ Then, click the drop-down arrow in the Sales column.

	♦ Select Number Filters > Greater Than.

	♦ Enter 3000 in the dialog box and click OK.

	♦ Click the drop-down arrow in the Product column

	♦ Select Text Filters > Laptop

Fig.1.3.10 Data after multiple filters

Result: Only rows with sales greater than 3000 in the “East” region are displayed.
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2. Filtering Based on Conditions

Excel allows you to filter data based on specific conditions, such as values greater 
than, less than, or equal to a particular number. This is useful for numeric or date-based 
filtering.

Example : Filter Sales Greater Than 300 

Fig. 1.3.11 Sales table

To filter sales greater than 300:

	♦ Click the filter dropdown in the Sales column header.

	♦ Choose Number Filters > Greater Than.

	♦ Enter 300 in the field and click OK.

Fig 1.3.12 Filtering sales greater than 300

3. Filtering Based on Text, Numbers, or Dates

You can filter data by text, numbers, or dates depending on the type of data in your 
columns.
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Text Filters

For columns with text data (e.g., names, categories, locations), you can filter based on 
conditions such as “begins with,” “contains,” or “equals.”

Example: Filter Products that Begin with “P”

Using the same dataset, filter products that begin with “P”:

	♦ Click the filter dropdown in the Product column.

	♦ Choose Text Filters > Begins With.

	♦ Enter P and click OK.

Number Filters

For numeric data (e.g., sales, prices), you can filter using logical conditions such as 
equal to, greater than, less than, or ranges.

Example: Filter Sales Equal to 300

To filter sales exactly equal to 300:

	♦ Click the filter dropdown in the Sales column.

	♦ Choose Number Filters > Equals.

	♦ Enter 300 and click OK.

Date Filters

For date-based data, Excel provides predefined date filters like Before, After, Between, 
or specific periods like Last Week or This Year.

Example: Filter Sales After a Specific Date

If your dataset contains dates, say the Sale Date column has values, and you want to 
filter sales after January 1, 2024:

	♦ Click the filter dropdown in the Sale Date column.

	♦ Choose Date Filters > After.

	♦ Enter 1-Jan-2024 and click OK.
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Exercise questions
1.	 Using a dataset of sales records, filter the data to show only sales from the 

“South” region.

2.	 You have a dataset of employees with their names, departments, and salaries. 
Filter the data to show only employees in the “HR” department with salaries 
greater than ₹ 50,000.
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Experiment 4
Introduction to Charts

Discussion

1.4.1 Introduction

Charts in Excel are visual tools that help represent data in a graphical format, making 
it easier to understand and analyze. Instead of looking at large sets of numbers, charts 
allow users to spot trends, compare values, and interpret information quickly. They are 
widely used in business reports, financial analysis, and presentations to display pat-
terns clearly. By using charts, data becomes more meaningful, making decision-making 
faster and more effective.

1.4.2 Theory

Microsoft Excel provides various chart types, including Bar Charts, Line Charts, and 
Pie Charts, which are commonly used for analysis and presentations. 

1.4.2.1 Types of Charts

1. Bar Chart

A Bar Chart represents data using rectangular bars of different lengths. It is useful for 
comparing values across categories.

Steps to Create a Bar Chart in Excel

1.	 Enter Data in Excel. Example

Table 1.4.1 Sales Table
Month Sales
Jan 5000
Feb 7000
March 6000
April 3000
May 8000

2.	 Select the data range (A1:B4).

3.	 Click on the Insert tab.
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4.	 Choose Bar Chart from the Charts section.

5.	 Select the Clustered Bar Chart option.

6.	 Your bar chart appears on the sheet.

Fig. 1.4.1 Bar chart of Sales in various months

2. Line Chart

A Line Chart connects data points using a continuous line, making it ideal for showing 
trends over time.

Steps to Create a Line Chart in Excel

1.	 Enter data in Excel, such as months and temperature values.

2.	 Select the data range.

3.	 Click on the Insert tab.

4.	 Choose Line Chart from the Charts section.

5.	 Select a Simple Line Chart.

6.	 The line chart appears, displaying trends.

80             SGOU - SLM - BSc - DS&A - Essential Excel Skills for Data Analysis



Fig. 1.4.2 Line chart of Temperature in various months

3. Pie Chart

A Pie Chart displays data as slices of a circle, showing proportions or percentages.

Steps to Create a Pie Chart in Excel

1.	 Enter category-based data (e.g., sales distribution per product).

2.	 Select the data.

3.	 Click on the Insert tab.

4.	 Choose Pie Chart from the Charts section.

5.	 Select 2D Pie Chart.

6.	 The pie chart appears with color-coded slices.
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Fig.1.4.3 Pie Chart of Departments and its expenses

4. Chart Elements

1. Chart Title

A chart title explains what the chart represents.

Click on the chart → Click Chart Elements (+ icon) → Select Chart Title → Type the 
title.

Fig. 1.4.4 Chart title 
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2. Axis Labels

Labels describe what the X-axis (horizontal) and Y-axis (vertical) represent.

Click on the chart → Click Chart Elements (+ icon) → Select Axis Titles → Type  
relevant labels.

Fig. 1.4.5 Axis title

3. Legends

Legends explain the colors or patterns in the chart, helping identify data categories.

Click on the chart → Click Chart Elements (+ icon) → Select Legend → Choose place-
ment (top, right, bottom, left).

Fig.1.4.6 Legend
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Exercise questions
Create a chart in Excel and customize its elements.

1.	 Open Microsoft Excel and enter the following data:

2.	 Select the data and create a Bar Chart to compare the sales of Product A 
and Product B.

3.	 Add the following Chart Elements: 
Chart Title: “Monthly Sales Comparison”

	 Axis Titles:

X-axis: “Month”

Y-axis: “Sales in ₹”

	 Legend: Place it at the bottom.

	 Save the Excel file and take a screenshot of your chart.

Create a Pie Chart and customize its elements.

1.	 Open Microsoft Excel and enter the following data:

2.	 Select the data and create a Pie Chart to show the budget distribution 
among departments.
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3.	 Add the following Chart Elements:
	� Chart Title: “Department Budget Allocation”
	� Data Labels: Display percentages inside each slice.
	� Legend: Place it on the right side of the chart.

4.	 Change the color theme of the chart to make it visually appealing.

5.	 Save the Excel file and take a screenshot of your chart.

6.	 Try using a 3D Pie Chart and compare it with the 2D version.
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2 Data Analysis 
Techniques
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Experiment 1
Advanced Formulas and  

Looping Functions
Discussion

2.1.1 Introduction

In this lesson, we will explore advanced formulas and lookup functions, which are 
essential for handling large datasets in spreadsheets. Functions like IF, AND, OR allow 
us to make logical decisions by evaluating conditions and returning specific results. 
These formulas are especially useful for applying rules, comparing values, and automat-
ing calculations. Additionally, we will learn about lookup functions such as VLOOKUP 
and HLOOKUP, which help us quickly find and retrieve specific data from large tables. 
Instead of manually searching for values, these functions enable efficient and accurate 
data retrieval. By mastering these advanced formulas and lookup functions, you will be 
able to manage data more effectively and enhance your ability to analyze and process 
information in spreadsheets.

2.1.2 Theory 

 In data analysis, tools like Excel and other spreadsheet software offer various functions 
that   help users organize, analyze, and interpret data, make decisions, and perform 
calculations quickly and accurately. Among these functions, logical functions such as 
IF, AND, and OR are especially important because they allow users to evaluate multiple 
conditions at once and automate complex decision-making processes. 

These logical functions work by testing whether certain conditions are true or false. 
Based on the result, they return different outputs or values. For example, if a student’s 
score is above a certain threshold, you can automatically label them as “Passed” or 
“Failed” using the IF function. By combining these logical functions, you can handle 
more complex situations, such as checking if a student meets both attendance and 
performance criteria before awarding a certificate.

2.1.3 IF

  The IF function checks whether a condition is true or false and returns one value if 
true, and another if false.
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Syntax:

=IF(logical_test, value_if_true, value_if_false)

Steps to Implement IF function
Step 1: Using the IF Function
Open Excel and create a table with a set of data. For example, use the following data:

Fig. 2.1.1 Original data

Step 2: Write the IF function to determine if each student has passed or failed

Use the formula in column C to display “Pass” if the marks are greater than or equal to 
50, and “Fail” otherwise.

Formula:

		  =IF(B2>=50, “Pass”, “Fail”)

Step 3: Drag down the formula for other rows in column C.   

Result:

Fig. 2.1.2 Result after IF function
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2.1.4 AND 

The AND function returns TRUE if all the given conditions are true. If any condition 
is   false, it returns FALSE.

Syntax:

=AND(logical1, logical2, ...)

Steps to Implement AND function

Step 1: Use the AND function to check if a student has achieved both the following:

	♦ Marks greater than or equal to 50.

	♦ Attendance greater than or equal to 75%.

Suppose you add an attendance column:

Fig. 2.1.3 Original data with attendance column

Step 2: Write the formula to check both conditions (Marks >= 50 AND Attendance >= 
75%):

Formula:

        =IF(AND(B2>=50, C2>=0.75), “Eligible”, “Not Eligible”)

Step 3: Drag down the formula to check the status for all students.
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Result 2.1.4 Result after AND function

2.1.5 OR  

The OR function returns TRUE if at least one condition is true. If all conditions are 
false, it returns FALSE.

Syntax:

=OR(logical1, logical2, ...)

Steps to Implement OR function

Step 1:Use the OR function to check if a student has either:

	♦ Marks greater than or equal to 50.

	♦ Attendance greater than or equal to 75%.

Step 2:Modify the formula to check for either condition:

Formula:

=IF(OR(B2>=50, C2>=0.75), “Eligible”, “Not Eligible”)

Step 3: Drag down the formula to apply it to all rows.

Result:
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Fig. 2.1.5 Result after OR function

2.1.6 Lookup Functions

Lookup functions are essential features in spreadsheet programs like Microsoft Excel 
and Google Sheets, designed to locate specific data within a table or a defined range 
of cells. They streamline the process of retrieving information, reducing the need for 
manual effort and saving significant time, especially when working with extensive 
datasets. These functions play a crucial role in managing, analyzing, and interpreting 
data by connecting related information spread across different rows and columns.

2.1.6.1  VLOOKUP

The VLOOKUP function, which stands for Vertical Lookup, is designed to locate a    
specific value in the first column of a data table and return related information from 
another column within the same row. This function is particularly useful for handling 
organized datasets, such as tables or lists.

Syntax:

=VLOOKUP(lookup_value, table_array, col_index_num, [range_lookup])

	♦ lookup_value: The value you want to search for.

	♦ table_array: The range of cells containing the data (must include the column 
with the lookup_value).

	♦ col_index_num: The column number in the table_array from which to return 
a result.

	♦ [range_lookup]: An optional argument:
	� Use TRUE for an approximate match (default).
	� Use FALSE for an exact match.
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Example: 

Imagine you have a list of students and their scores in a table, and you want to find the 
score of a specific student.

Fig. 2.1.6 Original data

Formula:

=VLOOKUP(“Bob”, A2:B4, 2, FALSE)

	♦ lookup_value: “Alice”

	♦ table_array: A2:B4 (includes both columns)

	♦ col_index_num: 2 (to return the value from the second column, “Score”)

	♦ range_lookup: FALSE (ensures an exact match).

Result: 
The formula returns 90, which is Alice score.

2.1.6.2  HLOOKUP

The HLOOKUP function, which stands for Horizontal Lookup, allows you to search 
for a specific value in the first row of a table or range and return the related data from 
a specified row beneath it. It is especially useful for working with data organized in a 
horizontal layout.
Syntax:

=HLOOKUP(lookup_value, table_array, row_index_num, [range_lookup])

	♦ lookup_value: The value you want to search for in the first row of the table.

	♦ table_array: The range of cells containing the data. The first row should 
contain the values to look up.

	♦ row_index_num: The row number in the table from which to retrieve data, 
starting with 1 for the first row.
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	♦ [range_lookup]: Optional argument:
	� Use FALSE for an exact match.
	� Use TRUE for an approximate match (default).

Example:

You have a table that contains months in the first row and sales figures for different 
regions in the rows below. You need to find the sales for March in Region 2.

Fig. 2.1.7 Sales data

Formula

=HLOOKUP(“March”, A1:E3, 3, FALSE)

Explanation:

	♦ lookup_value: “March”

	♦ table_array: A1:E3 (includes the entire table)

	♦ row_index_num: 3 (to return the value from the third row, Region 2)

	♦ range_lookup: FALSE (ensures an exact match).

Result: 
The formula returns 470, which is the sales figure for March in Region 2.
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Experiment questions

1.	 Create a spreadsheet for student grades with columns: Student Name, Marks, 
and Result. Use the IF function to determine whether each student has passed 
or failed. A student passes if the marks are 50 or above; otherwise, they fail.

2.	 Design an employee performance evaluation sheet with columns: Employee 
Name, Attendance (%), and Sales Target Achieved (Yes/No). Use the AND 
function to check if an employee qualifies for a bonus. The employee gets a 
bonus only if attendance is 90% or above and sales target is achieved.

3.	 Create a product inventory with columns: Product ID, Product Name, Price, 
and Stock Available. Use the VLOOKUP function to search for a product’s 
details when a Product ID is entered in a separate cell.

4.	 Create a fee structure table where different course names are listed in a row, 
and the fees for different semesters are listed below them. Use the HLOOKUP 
function to find the fee for a specific course in a given semester

5.	 Design a sheet with Employee Name, Years of Service, and Performance 
Rating to check special leave eligibility. Use the OR function to display 
“Eligible” if an employee has 5+ years of service or an “Excellent” rating; 
otherwise, show “Not Eligible”

94             SGOU - SLM - BSc - DS&A - Essential Excel Skills for Data Analysis



Experiment 2
Data Validation and Conditonal 

Formatting
Discussion

2.2.1 Introduction 

Data Validation and Conditional Formatting are powerful tools in Excel that help 
ensure data accuracy and improve visual presentation. Data Validation allows you to set 
rules for acceptable data input, preventing errors and ensuring consistency. Conditional 
Formatting lets you apply formatting based on cell values, helping to highlight important 
trends or anomalies. Together, these features make data more reliable and easier to 
analyze.​

2.2.2 Theory

Data validation and conditional formatting are powerful tools in spreadsheet software 
like Microsoft Excel, designed to improve data management and analysis.

Data validation helps ensure that the information entered into a spreadsheet is accurate 
and consistent by applying specific rules for acceptable inputs. It enables users to 
restrict entries to certain types of data, such as integers, dates, or predefined options 
from a drop-down menu. This feature is particularly valuable for minimizing errors and 
facilitating efficient data entry in large datasets.

Conditional formatting, on the other hand, offers a visually engaging way to analyze 
and interpret data by applying styles or colors based on predefined conditions. It can be 
used to emphasize significant details, reveal patterns, or highlight critical values. For 
instance, cells may be formatted with color gradients to reflect high or low values, or 
icons can be used to indicate performance levels.

2.2.2.1 Data Validation 

Data validation is a feature in Excel that helps control the type of data entered into a 
cell or range. By setting rules for acceptable values, it ensures data consistency and 
integrity. You can use data validation to restrict the data type (e.g., whole numbers, 
dates), create drop-down lists, and apply custom rules to control data entry.
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Steps to implement Data Validation
1.	 Select the cell or range where you want to apply data validation.

2.	 Go to Data–> Data Validation.

3.	 In the Settings tab, choose the validation criteria (e.g., Whole Number, Date, 
List).

4.	 For List validation, specify a list of allowed values or a range reference.

5.	 You can also set input messages or error alerts to guide the user.

Exercise 

1.	 Create a Drop-down List for Months

Suppose you have the following data in a table for the months of the year:

Fig.2.2.1 Sales data 
You want to create a drop-down list in the “Month” column so that users can only select 
months from a predefined list (January to December).
Steps:

1.	 Select the range B2:B5 (cells where the month values are to be entered).

2.	 Go to Data–> Data Validation.

3.	 In the Settings tab, choose List from the “Allow” dropdown.

4.	 In the Source box, type: 
January, February, March, April, May, June, July, August, September, 
October, November, December.

5.	 Click OK.
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Fig. 2.2.2 Step 2 of Data validation

Fig.2.2.3 Step 4 of data validation

Result:

Now, cells B2:B5 will have a drop-down list, and users will only be able to select a 
month from the list.
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Fig. 2.2.4 Result of data validation

2. Restrict Entry to Whole Numbers Between 1 and 500

Now, assume you want to restrict the Sales column to accept only whole numbers 
between 1 and 5000. You don’t want anyone entering values outside this range.

Fig. 2.2.4 Sales data
Steps:

1.	 Select the range C2:C5 (Sales column).

2.	 Go to Data–> Data Validation.

3.	 In the Settings tab, choose the Whole Number from the “Allow” dropdown.

4.	 Set the Data to “between,” and enter 1 in the Minimum field and 5000 in 
the Maximum field.

5.	 Click OK.
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Fig. 2.2.5 Step 3, 4 of Data validation

Result:

Now, if someone tries to enter a value in the Sales column that is greater than 5000 or 
less than 1, Excel will show an error message.

2.2.2.2 Conditional Formatting

Conditional formatting in Excel is a feature that allows you to format cells based on 
their values. This feature helps you visually analyze data by changing the appearance 
of cells when certain conditions are met. You can use it to highlight values, apply color 
scales, and add icons based on specific criteria.

Steps to implement Conditional Formatting:

1.	 Select the cell or range where you want to apply conditional formatting.

2.	 Go to Home –> Conditional Formatting.

3.	 Choose the type of formatting (e.g., Highlight Cells, Color Scales, Icon Sets).

4.	 Define the condition (e.g., greater than, less than, between, etc.).

5.	 Apply the desired formatting style (e.g., color fill, font change, etc.).
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Exercise 
1. Highlight Cells Greater Than 2000 in the Sales Column

Suppose the sales data for employees is entered, and you want to highlight all sales 
figures greater than 2000 in the Sales column.

Fig. 2.2.6 Sales data
Steps:

1.	 Select the range C2:C5 (Sales column).
2.	 Go to Home –> Conditional Formatting –> Highlight Cells Rules –> 

Greater Than.
3.	 In the dialog box, enter 2000 and choose a formatting style (e.g., red fill 

color).
4.	 Click OK.

Fig.2.2.7 Step 2 of conditional formatting
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Result:

Any cells in the Sales column with values greater than 2000 will now be highlighted 
with a red fill color.

Fig.2.2.8 Step 3 of conditional formatting

2. Apply a Color Scale to Show Value Distribution in Sales

Suppose you want to visually analyze the sales distribution using color, where lower 
sales are displayed in red and higher sales in green.

Fig. 2.2.9 Sales data
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Steps:
1.	 Select the range C2:C5 (Sales column).

2.	 Go to Home –> Conditional Formatting – > Color Scales.

3.	 Choose a color scale (e.g., red for low values and green for high values).

4.	 Click OK.

Result:

Any cells in the Sales column with lower sales are displayed in red and higher sales in 
green.

Fig. 2.2.10 Result after conditional formatting

Experiment questions

Q1.To use Data Validation in Excel to control the type and range of data entered into 
cells to ensure the integrity and consistency of an employee database.

Table 2.2.1 Employee data table
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1.	 Limit the age values to be between 18 and 100 to ensure employees are 
within a reasonable age range.

2.	 Ensure that the “Department” column contains only valid department names 
(HR, Marketing, IT, Finance).

Q2.You are given a dataset of student scores for a class in an Excel sheet. Your 
task is to apply conditional formatting to highlight specific ranges of scores.
Table 2.2.2  Dataset of student scores 

Steps:

1.	 Apply Color Scales: 
 Apply a two-color scale where the lowest scores are highlighted in red, 
and the highest scores are highlighted in green.

2.	 Highlight Scores Above 90: 
 Apply conditional formatting to highlight scores above 90 with a green fill 
color.

3.	 Highlight Scores Below 60: 
Apply conditional formatting to highlight scores below 60 with a red fill 
color.

Q3.To apply conditional formatting in Excel to analyze and highlight key sales 
performance metrics across different sales representatives.

Table 2.2.3  Sales performance of five persons

1. Highlight the sales representatives who have exceeded their target sales in green..

2. Highlight sales reps who did not meet their target in red.
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Experiment 3
Piviot Tables

Discussion

2.3.1 Introduction

A Pivot Table in Excel is a powerful tool that helps users organize, analyze, and extract 
insights from large datasets without altering the original data. It enables dynamic 
summarization, making it easier to analyze sales, performance trends, and expenses by 
applying operations like SUM, AVERAGE, COUNT, and more on grouped data. Pivot 
Tables allow users to categorize and filter data interactively using slicers or built-in 
filters, and they provide customization options for sorting and formatting layouts based 
on the analysis needs. This versatility makes Pivot Tables an invaluable tool for quickly 
identifying trends and making informed decisions.

2.3.2 Theory

2.3.2.1 Steps to Create a Pivot Table

1.	 Select Data:
	� Highlight the dataset or use a named range that includes column headers.

2.	 Insert Pivot Table:
	� Go to the Insert tab and click on the Pivot Table option.
	� Specify whether the pivot table should be created in a new worksheet or 

an existing one.

3.	 Design the Layout:
	� Drag and drop fields into the Rows, Columns, Values, and Filters areas 

in the Pivot Table Field Pane.

4.	 Customize:
	� Apply value field settings (e.g., sum or count).
	� Add calculated fields, grouping, and conditional formatting for enhanced 

analysis.



Example: Dataset of sales transactions.
Table 2.3.1 :  Dataset of sales transactions

1.	 Create a Pivot Table to analyze the total sales amount for each product in 
different regions.

Solution:
Creating the Pivot Table

	♦ Highlight the dataset (A1:D8).
	♦ Go to the Insert tab and select Pivot Table.

	♦ Place the Pivot Table in a new worksheet.

Configuring the Fields

	♦ Drag Region into the Rows area.

	♦ Drag Product into the Rows area below Region.

	♦ Drag Sales Amount into the Values area (ensure the aggregation is set to 
SUM).

	♦ Verify the total sales amount for each product in different regions.

Fig:2.3.1 Pivot  Table Layout.
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2.	 Modify the Pivot Table to show the sales amount split by months as columns.

Solutions:

Adding Months as Columns:

	♦ Drag Month into the Columns area.

	♦ The Pivot Table now shows sales amounts split by months.

Fig:2.3.2 Updated  Pivot  Table Layout.

3.	 Apply a filter to show data for only the East region

Solution:
Applying Filters:

	♦ Drag Region into the Filters area.
	♦ Use the dropdown filter to select East.

Fig:2.3.3 Filtered Pivot Table (East)
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2.3.2.2  Common Commands and Options:

1.	 Value Field Settings: Configure how numerical data is summarized (e.g., 
Sum, Average).

2.	 Grouping: Group data by categories, dates, or numeric ranges.

3.	 Slicers and Timelines: Add interactive filters for quick analysis.

4.	 Refresh: Update the Pivot Table if the underlying data changes.

Example: Dataset containing sales data for a retail store.

Table 2.3.1 :  Dataset of sales transactions.

1. Value Field Settings: 

i. Create a Pivot Table to calculate the average Profit for each Region. 
ii. Modify the Value Field Settings to show the data as an average instead of the 

default sum.

Solution:

	♦ Place the Region in the Rows area.

	♦ Place Profit in the Values area and set the aggregation to Average.

Fig:2.3.4 Filtered Pivot Table (East)
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2. Grouping by Date:

i. Group the sales data by Month using the Date field in the Pivot Table.

ii. Calculate the total Sales for each month.

Solution:

	♦ In the Pivot Table:
	♦ Place Date in the Rows area.
	♦ Group by Months using the Grouping feature.

	♦ Place Sales in the Values area (sum aggregation).

Output:

Fig:2.3.5  Filtered Pivot Table (East)

3. Slicers for Interactive Filters

i  Add a Slicer for the Region field to filter the Pivot Table dynamically.

ii. Use the Slicer to display data for the North region only and calculate the total 
Quantity sold.

Solution:Using the Slicer for Region (filtering North)

Output:
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Fig:2.3.6  Sliced Pivot Table (East)

4. Timelines for Date Analysis

i. Add a Timeline for the Date field to filter sales data for transactions in the first 
week of January (2024-01-01 to 2024-01-07).

ii. Calculate the total Profit for this period.

Solution: Using the Timeline to filter dates between 2024-01-01 and 2024-01-07:

Output:

Fig:2.3.7 Timeline in  Pivot Table.

5. Refresh Pivot Table

i.	 Suppose the dataset is updated, and the Sales for the South region’s Tablet 
on 2024-01-06 changes from 500 to 600.

ii.	 Refresh the Pivot Table and calculate the updated total Sales for the South 
region.
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Solution: After refreshing the Pivot Table:

Output:

Fig:2.3.8  Filtered Pivot Table

Experiment questions

1.	 Use the following dataset, which contains sales information for a retail 
store:

Table 2.3.2 :  Dataset of Sales Transactions

Tasks:

	♦ Create a Pivot Table to analyze total Sales for each Region.

	♦ Create another Pivot Table to calculate the total Quantity sold for each 
Product across all regions.

	♦ Add a Filter: Modify the first Pivot Table (Region vs. Sales) to include only 
regions where total Sales exceed $1500.
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	♦ Analyze Profit by Category: Create a Pivot Table to calculate the average 
Profit for each Category (Electronics and Accessories).

2.	 Use the following dataset that contains sales and customer data for a retail store:

Table 2.3.3 :  Dataset of Sales Transactions.

Tasks:

	♦ Create a Pivot Table to Calculate Total Sales for Each Region

	♦ Create a Pivot Table to Calculate the Total Quantity Sold for Each Product

	♦ Filter to Show Only Products with Sales Over $1000

	♦ Analyze Average Profit by Category

	♦ Add a Slicer for Product
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Experiment 4
Named Ranges

Discussion

2.4.1 Introduction

Named Ranges in Excel allow you to give a simple name to a group of cells, making it 
easier to work with your data. Instead of using cell references like A1:A10, you can use a 
name like Sales Data, which makes your formulas clearer and easier to understand. This 
is especially helpful in large or complex spreadsheets, as it makes navigation simpler, 
reduces mistakes, and allows you to use the names in different sheets or workbooks.

2.4.2 Theory

Named ranges in Excel provide a way to assign a unique, descriptive name to a cell or 
range of cells. This helps improve formula readability and makes data easier to manage.
Named ranges can be used across the entire workbook, allowing for quicker navigation 
and clearer formulas. They also help reduce errors, as it’s easier to understand and work 
with names than complex cell references. Named ranges enhance both the organization 
and clarity of your spreadsheets.

2.4.2.1 Creating Named Ranges

Creating Named Ranges is straightforward and can be done in multiple ways.

Steps to Create a Named Range:

1.	 Using the Name Box:

	♦ Select the range of cells you want to name.

	♦ Click on the Name Box (left of the formula bar).

	♦ Type the desired name (e.g., MonthlyExpenses) and press Enter.

2.	 Using the Define Name Option:

	♦ Go to the Formulas tab and click Define Name.

	♦ In the New Name dialog box:
	� Enter the name.
	� Specify the range in the “Refers to” box.

	♦ Click OK.



3.	 Shortcut Method:

4.	 Use Ctrl + F3 to open the Name Manager, then click New to create a 
Named Range.

Naming Rules

	♦ Must start with a letter or underscore.

	♦ Cannot include spaces (use underscores instead, e.g., Net_Profit).

	♦ Cannot conflict with cell references (e.g., A1 is invalid).

2.4.2.2 Managing Named Ranges in Formulas

After creating Named Ranges, you can use them in formulas, edit them, or delete them 
if no longer needed.

Using Named Ranges in Formulas:

	♦ Replace cell references with Named Ranges (e.g., =SUM(SalesData)).

	♦ Combine with functions for better readability 
(e.g.,=AVERAGE(Revenue2023)).

Editing or Deleting Named Ranges:

1.	 Open the Name Manager:

	♦ Go to the Formulas tab and click Name Manager or press Ctrl + F3.

2.	 Edit a Named Range:

	♦ Select the name and click Edit.

	♦ Update the name or the referenced range.

3.	 Delete a Named Range:

	♦ Select the name in the Name Manager and click Delete.

Exercise 

1.	 You are provided with the following dataset of employee performance 
scores:
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Table 2.4.1 Dataset of Employee Performance Scores

Tasks:

1.	 Introduce Named Ranges for the following:

	♦ Employee names (Employees)

	♦ Department names (Departments)

	♦ Performance scores (Scores)

2.	 Use a Named Range to calculate the average performance score.

3.	 Edit the Named Range Scores to exclude David’s score, and recalculate the 
average performance.

4.	 Delete the Named Range Departments.

Solution:

1.	 Creating Named Ranges:

	♦ Highlight the range A2:A6 (Employee names).

	♦ Go to the Formulas tab and click Define Name.

	♦ Enter Employees in the Name box and click OK.

	♦ Repeat the same process for:
	� B2:B6 (Department names) as Departments.
	� C2:C6 (Performance scores) as Scores.

2.	 Named Ranges Created:

	♦ Employees: A2:A6

	♦ Departments: B2:B6

	♦ Scores: C2:C6
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3.	 Calculating Average Performance Score:

	♦ In any cell, type the formula: 
=AVERAGE(Scores)

	 =86.6

4.	 Editing the Named Range Scores:

	♦ Press Ctrl + F3 to open the Name Manager.

	♦ Select Scores and click Edit.

	♦ Update the range to C2:C5 (excluding David’s score).

	♦ Click OK.

	♦ Recalculate the average by typing: 
=AVERAGE(Scores)=85.25

         	

5.	 Deleting the Named Range Departments:

	♦ Open the Name Manager (Ctrl + F3).

	♦ Select Departments and click Delete.

	♦ Confirm the deletion.

Fig. 2.4.1 Name manager window
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Experiment Questions

1.	 Create the following dataset in excel and perform the task given.

Table 2.4.2 Dataset of five fruits with their price and quantity

	♦ Create named ranges for the following:
	� Product_List for the Product column.
	� Prices for the Price column.
	� Quantities for the Quantity column.

	♦ In another cell, calculate the total revenue using the named ranges (Price × 
Quantity for all products).

2.	 Consider the following dataset

Table 2.4.3 Sales details of five fruits

	♦ In a new worksheet, attempt to create the following named ranges. Identify 
which ones follow the naming rules and which ones don’t:

	� Total_Profit
	� Sales2024
	� 1st_Quarter
	� Revenue$
	� Region-Area
	� _DiscountRate

	♦ Correct the invalid names and apply them to corresponding data ranges.
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3
Data 

Visualisation 
and 

Dashboarding



Experiment 1
Advanced Visualisations

Discussion

3.1.1 Introduction

In this experiment, you will explore advanced visualization techniques in Excel, 
including scatter plots, histograms, combo charts, and trendlines. These tools help in 
analyzing data patterns, identifying relationships, and making data-driven decisions. 
You will learn how to create and customize these visualizations to effectively represent 
complex datasets. By the end of this experiment, you will be able to apply best practices 
in data visualization for clear and meaningful insights.

3.1.2 Theory

3.1.2.1 Histogram

A histogram is a graphical representation of data distribution that organizes numerical 
data into continuous intervals, called bins. Unlike bar charts, which compare discrete 
categories, histograms depict the frequency of data points within specified ranges, 
making them useful for analyzing patterns, trends, and variations in large datasets. The 
x-axis represents the data intervals, while the y-axis shows the frequency or count of 
values within each bin.

Steps to Create a Histogram:

1.	 Prepare a dataset in Excel with a column for the data values.

2.	 Select the data range.

3.	 Go to the Insert tab.

4.	 Click on Insert Statistic Chart and choose Histogram.

5.	 Customize the bins using the Format Axis pane.



Exercise Question:
Sample Data (Exam Scores)
Table 3.1.1 Exam Score Data

Student Score
John 85
Jane 78
Sam 92
Alice 88
Bob 65
Emma 79

Resulting Histogram:

The histogram will group scores into bins and show the frequency of scores within each 
range.

Output

Fig 3.1.1 Histogram output with data

Fig 3.1.2  Histogram Output
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3.1.2.2 Scatter Plots

A scatter plot is a powerful visualization tool used to analyze the relationship between 
two numerical variables. Each point on the plot represents a data pair, with one variable 
mapped to the x-axis and the other to the y-axis. This chart is particularly useful for 
identifying patterns, trends, and correlations, such as positive, negative, or no correlation 
between variables. 

Steps to Create a Scatter Plot

1.	 Prepare a dataset with two numeric columns (e.g., X and Y values).

2.	 Select the data range.

3.	 Go to the Insert tab.

4.	 Click on Insert Scatter (X, Y) or Bubble Chart.

5.	 Format the chart as needed.

Exercise Question

Sample Data (Height vs. Weight):

Table 3.1.2 Height vs. Weight Data
Person Height 

(cm)
Weight 

(kg)
John 170 70

Jane 160 55

Sam 180 80

Alice 165 65

Bob 175 75

Resulting Scatter Plot:

The scatter plot shows the relationship between height and weight.
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Output

Figure 3.1.3 Scatter Plot Output

3.1.2.3  Combo Charts 

A combo chart is a versatile visualization tool that combines two or more chart types, 
such as bar and line charts, to effectively represent multiple data series with different 
visualization styles. This type of chart is particularly useful when comparing datasets 
with varying scales or highlighting trends alongside categorical data. By integrating 
different chart types, a combo chart provides a clearer understanding of complex 
relationships within the data. 

Steps to Create a Combo Chart

1.	 Prepare a dataset with at least two data series.

2.	 Select the data range.

3.	 Go to the Insert tab.

4.	 Click on Insert Combo Chart.

5.	 Choose a chart type for each series and customize.

121          SGOU - SLM  - BSc - DS&A - Essential Excel Skills for Data Analysis



Exercise Question:

Sample Data (Sales and Profit):

Table 3.1.3 Sales and Profit data
Month Sales Profit

Jan 2000 500

Feb 2500 700

Mar 2200 650

Apr 3000 900

May 2700 800

Resulting Combo Chart:

A column chart for sales and a line chart for profit over months.

Output

Figure  3.1.4 Combo chart output

3.1.2.4 Trendlines

Trendlines are an essential analytical tool used in charts to identify patterns, trends, 
and the overall direction of data over time. They are commonly applied to line 
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charts, scatter plots, and combo charts to highlight underlying trends, making 
it easier to interpret long-term movements and relationships within a dataset.  

Steps to Add a Trendline

1.	 Select a chart (e.g., scatter plot or line chart).

2.	 Click on a data series.

3.	 Go to Chart Tools and select Add Trendline.

4.	 Choose the type of trendline (e.g., linear, exponential).

5.	 Customize and display the equation if needed.

Exercise Question

Sample Data (Yearly Sales):
Table 3.1.4 Yearly Sales data

Year Sales

2018 5000

2019 6000

2020 7000

2021 8000

2022 9000

Resulting Chart with Trendline:

The trendline shows the increasing sales trend over years.
Output

Fig 3.1.5 Scatter plot before drawing a Trendline
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Fig. 3.1.6 After drawing a trendline on that scatter plot

Experiment Questions

1.	 Generate a histogram to display the frequency of employees’ ages in a 
company.

2.	 Create a histogram to categorize product sales data into predefined ranges..

3.	 Create a histogram to analyze customer purchase amounts and identify the 
most common range of spending. 

4.	 Create a scatter plot to study the relationship between advertising expenses 
and sales revenue.

5.	 Generate a scatter plot to analyze the correlation between hours studied and 
test scores for students.

6.	 Use a combo chart to analyze yearly profits for two different branches of a 
company.

7.	 Add meaningful labels, a title, and a legend to a combo chart for better 
interpretation.

8.	 Apply an exponential trendline to a chart showing population growth over 
the years

9.	 Use a polynomial trendline to analyze fluctuations in monthly website 
traffic.
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Experiment 2
Interactive Dashboards and 

Data Fitering
Discussion

3.2.1 Introduction 

In this experiment, you will learn how to create interactive dashboards in Excel using 
slicers and timelines for efficient data filtering. Dashboards help in visualizing key 
insights by combining multiple charts, tables, and filters into a single interactive view. 
Slicers provide an easy way to filter data dynamically, while timelines allow filtering 
based on date ranges. By following data visualization best practices, you will design 
dashboards that are clear, insightful, and user-friendly, enabling better decision-making 
and analysis.

3.2.2 Theory

3.2.2.1 Dashboards

Dashboards provide a visual summary of key metrics, allowing users to explore and 
analyze data interactively. They integrate multiple elements, such as charts, slicers, 
pivot tables, and conditional formatting, to present a comprehensive and dynamic view 
of data. By consolidating information from various sources into a single interface, 
dashboards enhance data-driven decision-making and improve efficiency. 

Steps to Create an Interactive Dashboard

1.	 Prepare a clean dataset.

2.	 Insert pivot tables and charts for key metrics.

3.	 Add slicers to filter data interactively.

4.	 Use timelines for date-based filtering.

5.	 Arrange charts and slicers on a single sheet.
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Exercise Question

Sample Data

Dataset containing sales, regions, and product details.
Table 3.2.1 Dataset containing sales, regions, and product details

Region Product Sales Quantity 

Sold

Profit Margin

(%)

North Product A 25000 120 20

South Product B 40000 200 25

East Product C 35000 150 18
West Product D 20000 80 15
North Product E 30000 140 22

South Product F 45000 210 28

East Product G 50000 250 30

Resulting Dashboard: 

	♦ Interactive charts showing sales trends, product performance, and regional 
analysis with slicers for filtering by region or product.

Output 

Fig. 3.2.1 Dashboard 
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3.2.2.2  Using Slicers and Timelines for Filtering Data

Slicers are interactive visual filters used in Excel to refine and filter data 
dynamically within pivot tables and charts. They provide an intuitive and user-
friendly way to segment data by selecting specific categories, making data analysis 
more efficient. Unlike traditional drop-down filters, slicers display filter options 
as clickable buttons, allowing users to apply multiple filters simultaneously. 
Steps to Add Slicers and Timelines:

1.	 Create a pivot table or chart.

2.	 Go to the PivotTable Analyze tab.

3.	 Click Insert Slicer or Insert Timeline.

4.	 Select the fields to filter.

Exercise Question

Sample data

Table 3.2.2 Sales and Product dataset
Date of Sales Region Product Sales (INR)

2024-01-01 North Laptop 1500

2024-01-02 South Smartphone 800

2024-01-03 East Tablet 600

2024-01-04 West Smartwatch 400

2024-01-05 North Headphones 200

2024-01-06 South Laptop 1400

2024-01-07 East Tablet 650

2024-01-08 West Smartphone 750

2024-01-09 North Smartwatch 450

2024-01-10 South Headphones 300

Resulting Visualization

Filter data dynamically using slicers and timelines.

Output
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 Fig. 3.2.2  Pivot Table for the above dataset

Fig. 3.2.3  Result after using Filters
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3.2.2.2  Data Visualization Best Practices 

	♦ Use simple and clear charts to convey your message.

	♦ Choose appropriate chart types for the data.

	♦ Avoid clutter and unnecessary decorations.

	♦ Use consistent colors and labels.

	♦ Ensure the visualizations are accessible and readable. 

Data visualization is an essential technique for representing complex data in a clear and 
understandable way. Effective visualizations help in identifying patterns, trends, and 
insights that may not be obvious in raw data. Following best practices ensures clarity, 
accuracy, and accessibility in data presentation. 

Best Practices for Effective Data Visualization 

1.	 Use Simple and Clear Charts

The primary goal of data visualization is to communicate information effectively. Using 
simple and uncluttered charts helps convey the message without confusion. Avoid 
excessive design elements that do not add value to the visualization.

2.	 Choose the Appropriate Chart Type

Selecting the right chart type is crucial for accurate data representation:

	♦ Bar Charts – Best for comparing categorical data.

	♦ Line Charts – Ideal for showing trends over time.

	♦ Pie Charts – Suitable for displaying proportions but should be used sparingly.

	♦ Scatter Plots – Useful for showing relationships between two variables.

3.	 Use Consistent Colors and Labels

Colors and labels play a vital role in enhancing readability:

	♦ Use a consistent color scheme to avoid confusion.

	♦ Choose contrasting colors to differentiate data categories.

	♦ Ensure labels are clear, legible, and positioned correctly.

4.	 Ensure Accessibility and Readability

A good visualization should be understandable to all users, including those with visual 
impairments. To enhance accessibility:

	♦ Use colorblind-friendly palettes. 
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	♦ Provide alternative text descriptions for visual elements.

	♦ Use appropriate font sizes and avoid overly complex designs.

Exercise Questions

1.	 Create a well-designed sales dashboard with clear charts and meaningful 
labels with the given dataset. 

Table 3.2.3 Product sales data
Region Date of 

Sales
 Product Sale 

Amount 
North 2024-01-01 Laptop 50000
South 2024-01-02 Smartphone 18000

East 2024-01-03 Tablet 6000
West 2024-01-04 SmartWatch 4000
North 2024-01-05 Headphones 800
South 2024-01-06 Laptop 40000
East 2024-01-07 Tablet 6500
West 2024-01-08 Smartphone 17500
North 2024-01-09 Smartwatch 4500
South 2024-01-10 Headphone 900

	 Output

Fig 3.2.4  Sales Dashboard 
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Experiment Questions

1.	 Incorporate a scatter plot and histogram into an interactive dashboard for 
data exploration.

2.	 Build a dashboard to track inventory levels and order trends for different 
product categories.

3.	 Use a timeline to filter sales data by year and quarter in a pivot table.

4.	 Create a chart that updates dynamically based on slicer selections for region 
and salesperson.

5.	 Combine slicers and timelines in a dashboard to explore monthly sales trends 
for specific products.

6.	 Create a bar chart that adheres to data visualization best practices by avoiding 
clutter and unnecessary 3D effects.

7.	 Design a pie chart for market share distribution with a focus on clear labels 
and meaningful colors.

8.	 Create a line chart for stock price trends and ensure accessibility for viewers 
with color blindness.

131          SGOU - SLM  - BSc - DS&A - Essential Excel Skills for Data Analysis



Experiment 3
Importing Data and External Sources

Discussion

3.3.1 Introduction

In today’s digital world, data is stored in formats like CSV files and online databases. 
Instead of manual entry, we can import data from websites and CSV files to save time 
and reduce errors. This lesson covers efficient data importing into spreadsheets or data-
bases, helping you manage large datasets, analyze information, and streamline your 
workflow.

3.3.2 Theory

In data management, working with large datasets is common, and manually entering 
data can be time-consuming and prone to errors. To handle data efficiently, we can 
import data from external sources, such as websites and CSV files. This process 
allows us to bring in structured data quickly and accurately, making analysis and 
decision-making easier.A CSV (Comma-Separated Values) file is a simple text file that 
stores data in a structured format, where each value is separated by a comma. Many 
applications, including spreadsheets and databases, support CSV files, making them a 
popular format for data exchange. Importing a CSV file allows us to work with large 
amounts of data without manually typing it.Similarly, importing data from websites 
enables us to retrieve real-time information, such as stock prices, weather updates, or 
financial reports, directly into a spreadsheet or database. This helps keep data updated 
and relevant without the need for repeated manual entry.By learning how to import data 
from external sources, you will be able to manage information more effectively, improve 
accuracy, and save time when working with large datasets. This skill is essential for 
handling real-world data efficiently and making informed decisions based on accurate 
and up-to-date information.

3.3.2.1 Importing Data from a WebsiteSelect Data

Steps 

1.	 Open a new Excel workbook.

2.	 Go to the `Data` tab.



3.	 Select `From Web`.

4.	 Enter the URL of the website from which you want to import data. (https://
drive.google.com/uc?id=1phaHg9objxK2MwaZmSUZAKQ8kVqlgng4&e
xport=download)

5.	 Click `OK` and wait for Excel to connect to the website and load the data.

6.	 Select the data you want to import and click `Load`.

Example Dataset: Let’s say you are importing daily weather data from a website(URL: 
https://drive.google.com/uc?id=1phaHg9objxK2MwaZmSUZAKQ8kVqlgng4&expor
t=download) 

After importing, your data might look like this:

Fig 3.3.1 Entering the URL for importing the data
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Fig 3.3.2 Entered URL for importing

Fig 3.3.3 Sample Data
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Fig 3.3.4 Importing from Web site

Fig 3.3.5 Imported data displayed in Excel

Result 

After importing, the data will be displayed in Excel as a table, and you can perform 
various analyses such as sales trends and product performance comparisons.

Exercise Questions 

1.	 Import daily weather data from a weather forecasting website and analyze 
the temperature variations over a week.

2.	 Import exchange rate data from a financial website and create a line chart to 
visualize currency fluctuations over a month.
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3.	 Import stock price data from a stock market website and calculate the moving 
average for a selected stock.

4.	 Import population statistics from a government website and create a bar 
chart to represent the population distribution across different states.

5.	 Import sports statistics from a sports website and compare the performance 
metrics of two athletes.

6.	 Import COVID-19 case data from a health organization’s website and 
analyze the trend of new cases over time.

3.3.2.2 Importing Data from CSV Files

Steps 

1.	 Click on “Get Data” → “From File” → “From Text/CSV”.

2.	 Enter the CSV URL (e.g., https://raw.githubusercontent.com/datablist/
sample-csv-files/main/people/people-100.csv) and click Import.

3.	 Excel will display a preview of the data. Click Load to import it into your 
workbook.

Fig 3.3.6: Importing Data from a CSV File in Excel

136             SGOU - SLM - BSc - DS&A - Essential Excel Skills for Data Analysis



Fig 3.3.7 :Import data

Fig 3.3.8 :Preview of Data

Result

After importing, the data will be displayed in Excel as a table, and you can perform 
various analyses such as sales trends and product performance comparisons.

137          SGOU - SLM  - BSc - DS&A - Essential Excel Skills for Data Analysis



Exercise Questions

1.	 Import sales data from a CSV file and create a pivot table to summarize sales 
by product category.

2.	 Import employee information from a CSV file and create a scatter plot to 
analyze the relationship between years of experience and salary.

3.	 Import customer feedback data from a CSV file and create a word cloud to 
visualize the most common feedback terms.

4.	 Import transaction data from a CSV file and use conditional formatting to 
highlight transactions exceeding a certain amount.

5.	 Import survey results from a CSV file and create a pie chart to display the 
distribution of responses to a specific question.

6.	 Import inventory data from a CSV file and create a combo chart to visualize 
stock levels and reorder points.

138             SGOU - SLM - BSc - DS&A - Essential Excel Skills for Data Analysis



Experiment 4
Collaboration and Protection in Excel

Discussion

3.4.1 Introduction

In today’s fast-paced and interconnected work environment, collaboration is key to 
success. Microsoft Excel provides a range of tools and features that enable users to 
share, protect, and collaborate on workbooks with others. This lab manual will explore 
the various ways to collaborate with others in Excel, including sharing workbooks, 
protecting sensitive data, tracking changes and comments, and working together in 
real-time using Excel Online or shared workbooks.

3.4.2 Theory

Sharing a workbook in Excel enables collaboration and accessibility, allowing multiple 
users to view, edit, or comment on a single document.  Protecting worksheets and 
workbooks in Excel prevents unauthorized users from making changes, while allowing 
authorized users to access and edit the data. By using passwords, permissions, and 
protection features, such as locking cells and worksheets, users can secure their Excel 
files and maintain data integrity. Excel Online allows multiple users to work on the 
same workbook simultaneously, improving collaboration and efficiency.

3.4.2.1  Sharing workbook with others

Sharing workbooks enables collaboration among team members, allowing them to view 
and edit the same document simultaneously.

Steps to sharing workbook with others:

1.	 Open the workbook you want to share.

2.	 Go to the `File` tab.

3.	 For Microsoft Office 2010: Select Save and Send

4.	 Select `Share` and choose the sharing method (via email, OneDrive, or 
SharePoint).

5.	 Follow the prompts to send the workbook to others.
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Fig: 3.4.1   Sharing Workbooks with Others

Exercise Question

Dataset: Consider a financial report that you want to share with your team:
Month Revenue 

(₹)
Expenses 

(₹)
Profit 
(₹)

Jan 1,00,000 50,000 50,000

Feb 1,20,000 60,000 60,000

Mar 1,10,000 55,000 55,000

Apr 1,30,000 65,000 65,000

May 1,40,000 70,000 70,000

Result: Sharing the workbook allows team members to view and edit the data, providing 
real-time updates and collaborative insights.

3.4.2.2  Protecting Worksheets and Workbooks

Protecting worksheets and workbooks ensures data integrity and prevents unauthorized 
changes.

Steps to Protect a Worksheet

1.	 Go to the `Review` tab.

2.	 Click on `Protect Sheet` and set a password if desired.
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3.4.2.2.2 Steps to Protect a Workbook:

1.	 Go to `File`, then `Info`, and select `Protect Workbook`.

2.	 Choose the desired protection options.

Fig: 3.4.2  Protect a worksheet

Protecting Worksheets and Workbooks in Microsoft Office 2010

Protecting your worksheets and workbooks is essential to maintain data integrity and 
prevent unauthorized changes. Here’s how you can safeguard your data in Microsoft 
Office 2010:

Protecting a Worksheet:

1.	 Open the worksheet you want to protect.

2.	 Go to the Review tab in the ribbon.

3.	 Click on Protect Sheet.

4.	 Set a password (optional) to prevent others from removing the protection.

5.	 Select the elements you want to allow users to edit (e.g., select “Select locked 
cells” and “Select unlocked cells”).

6.	 Click on OK.

Protecting a Workbook:

1.	 Open the workbook you want to protect.

2.	 Go to the Review tab in the ribbon.
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3.	 Click on Protect Workbook.

4.	 Set a password to protect the structure and windows of the workbook.

5.	 Click on OK.

Fig:3.4.3 Protected   Sheet

Examples of Protecting Worksheets and Workbooks

Example Dataset:  A  budget plan

Table 3.4.2.2.1 :Dataset of a budget plan
Category Planned (₹) Actual ₹) Variance (₹)

Materials 50,000 45,000 5,000

Labor 30,000 32,000 -2,000

Transportation 10,000 8,000 2,000

Miscellaneous 5,000 4,500 500

Result: Protecting the worksheet ensures that only authorized users can make changes, 
maintaining data integrity.
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Fig:3.4.4  Protected worksheet

3.4.2.3  Tracking Changes and Comments

Tracking changes and adding comments helps in collaborative environments by 
providing a history of edits and facilitating communication among users.

Steps to Track Changes:

1.	 Go to the `Review` tab.

2.	 Click on `Track Changes` and select `Highlight Changes`.

Fig: 3.4.2.3.1 Track changes window
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3.4.2.3.2 Steps to Add Comments

1.	 Select the cell you want to comment on.

2.	 Go to the `Review` tab and click on `New Comment`.

Fig: 3.4.5  Track Changes comment window

Example of Tracking Changes and Comments

Example Dataset: Consider a project timeline with tasks and deadlines:

Table : 3.4.2  Dataset Task and Deadline
Task Assigned To Due Date Status

Design Phase John 2024-12-10 Completed

Development Jane 2025-01-20 In Progress

Testing Sam 2025-02-15 Not Started

Deployment Alice 2025-03-05 Not Started

Result: Tracking changes and adding comments helps monitor task progress and allows 
team members to provide feedback and updates.

3.4.2.4 Collaborating in Real-Time Using Excel Online

Steps to Collaborate in Real-Time.

1.	 Save the workbook to OneDrive.

2.	 Open the workbook in Excel Online.
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To do this by uploading your Excel file to OneDrive or SharePoint and then opening it 
in Excel Online.

3.	 Share the Workbook.

Click on the “Share” button in the top-right corner.

4.	 Multiple users can now edit the workbook simultaneously and see changes 
in real time.

Questions
1: Sharing a Workbook

Steps to share a Workbook:

1.	 Go to the Excel Online website and sign in with your Microsoft account.

2.	 Click on the “New” button to create a new workbook.

3.	 Enter some sample data into the workbook.

4.	 Click on the “Share” button in the top-right corner of the screen.

5.	 Enter the email address of the person you want to share .

6.	 Choose the permission level you want to assign to the user (e.g. “Editor”, 
“Viewer”).

7.	 Click on the “Share” button to share the workbook.

2: Real-Time Co-Authoring

Steps to Real-Time Co-Authoring:

1.	 Create a new workbook in Excel Online.

2.	 Share the workbook with a colleague or classmate.

3: Using Comments

Steps to Add Comments:

1.	 Create a new workbook in Excel Online.

2.	 Add a comment to a cell.

3.	 Share the workbook with a colleague or classmate.

4.	 Observe  the colleague or classmate respond to the comment.

4: Collaborating with Multiple Users
Steps to Collaborate with multiple Users:

1.	 Create a new workbook in Excel Online.

2.	 Share the workbook with multiple colleagues or classmates.

3.	 Observe the changes in real-time.
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